x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FBX multi animations import for 1 mesh issue

Hello,

So I have this weird issue where I created several animations in MAYA 2016 for a building. I then export the FBX (using the "Export to UE" function) with the full range of animated frames (from frame 1 to frame 410). Because my buildings does not use bones I check "Resample All" in the FBX export options to make sure the animations are baked.

When importing in UE4, I import the animations separately (e.g.: animation 1 = frame 1 to frame 40, animation 2 = frame 41 to frame 60, animation 3 = frame 61 to frame 100, etc.). All the animations works well except the animation number 2 ... On that one, the scale of some elements inside the animation as well as their translation into space is wrong.

The weird thing is, if I import all the frames in one single animation file (frame 1 to 410), everything looks fine, as it is in Maya... Also, if I open the animation 2 (when imported individually) to check it and I add a Curve, the scale and animation are restored as they should be, but UE4 prompt me to hit the "Apply" button to validate changes, although, if I do that, the animation is wrong again !!

alt text

I tried almost every possible combination of export/import parameters, I have been searching a solution to this but had no luck, it is driving me crazy @_@ !

Product Version: UE 4.12
Tags:
animissue.jpg (214.5 kB)
more ▼

asked Jul 13 '16 at 03:40 PM in Using UE4

avatar image

Dinfael
154 5 19 21

avatar image Dinfael Jul 14 '16 at 01:50 AM

So I have been searching some more and could not find any solution yet. Tried to import the same animation but with some more frames before and after and the problem persist. Help !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello again,

By trial I happened to "solve" the issue using the "Additive Anim Type" set to "Local Space" and "Base Pose Type" set to "Reference Pose" . If I understand correctly, this allows the meshes in the anim. to take attributes from the reference animation (pose).

So, now my animation displays correctly.

BUT, this is not really a solution, I think. I mean, this is the only animation out of 6 different animations that had this issue. Why is it so ? Can anyone point me to where the issue come from ? Is it in the way I animated the mesh ? I don't think so as I animated the whole scene the same way. Then, what is it ? Thank you in advance...

more ▼

answered Jul 14 '16 at 02:49 AM

avatar image

Dinfael
154 5 19 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question