x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reflections are black after packaging for Gear VR

I am using UE4 for a Gear VR project on the S7.

The reflections are visible in the editor and even in Oculus, but whenever I put the build on Gear VR, the object appears solid black. The object is in an exterior environment, with lighting baked into the diffuse texture. I have one dynamic directional with no shadows casting, a static skylight (I've also tried stationary skylight and static directional), and a sphere with an HDRI applied for the skydome.

I have resorted to testing this with a single sphere mesh and a material. There is nothing else in the scene, except the sky dome.

Diffuse - gray Metallic - 1 Roughness - 0

I have tried using a sphere reflection capture actor with both "specified cubemaps" and "captured scene." Both render black.

Screen Space Reflections are turned off in the rendering settings and in the post process volume.

I have also tried putting the cubemap into the material with a reflection vector, in both/either the base color and emissive nodes. It still renders black.

Mobile HDR is off.

Here are my android device profiles settings.

alt text

Does anyone have any ideas of what could be causing this?

Product Version: UE 4.12
Tags:
capture.png (35.4 kB)
more ▼

asked Jul 13 '16 at 10:20 PM in VR

avatar image

Anngelica
26 1 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I migrated the project, started fresh, and was able to get a little bit of reflection using only static lighting and a sphere reflection capture actor without cubemaps. At this point, I'm not sure what my problem was or what might have fixed it, but at least it's working. Sorry I couldn't help anyone having the same issue.

Thanks for the response, Tim!

more ▼

answered Jul 29 '16 at 06:03 PM

avatar image

Anngelica
26 1 3 5

avatar image Tim Hobson ♦♦ STAFF Jul 29 '16 at 06:30 PM

Glad you've got it sorted. Should the issue reappear feel free to post back here and we can take a look at the issue again. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Anngelica,

At the moment I'm not seeing this on the device I have to test with, which is a Galaxy Note4.

Can you tell me the following:

  • Do you get the same result if you're not packaging for GearVR on the Android device?

  • If it's happening only in GearVR can you give the full specs for the S7 you're using? Specifically, if it's Mali or Adreno.

  • Is this only happening in your project or does it happen in a blank project as well?

If you want to include a sample project that reproduces the issue that would be helpful as well.

Thank you!

Tim

more ▼

answered Jul 15 '16 at 06:07 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question