x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cooking for Mac - AutomationTool issue

We're running UE 4.12.5 and I've been trying to get our game cooked on the Mac.

I started by compiling the ShaderCompilerWorker and the Editor, and this works great. We can load up the project and play it in the editor.

However, when I select that I want to cook the game I get an error from the AutomationTool.exe that it sent a SIGSEV error.

I tried to follow steps in the answer of this post: https://answers.unrealengine.com/questions/313380/automation-tool-failed-to-run-successfully-1.html

When I get to compiling UnrealPak, I get this error:

Building UnrealPak... 2016-07-14 07:36:42.694 defaults[62228:2597939] The domain/default pair of (/Users/mike/Library/Preferences/com.apple.dt.Xcode, IDEBuildOperationMaxNumberOfConcurrentCompileTasks) does not exist Running command : Engine/Binaries/DotNET/UnrealBuildTool.exe UnrealPak Mac Development Compiling with MacOSX SDK 10.11 Performing 3 actions (12 in parallel) [1/3] Link UnrealPak ld: can't write output file: /Users/mike/Development////UnrealEngine/Engine/Binaries/Mac/UnrealPak for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) ERROR: UBT ERROR: Failed to produce item: /Users/mike/Development////UnrealEngine/Engine/Intermediate/Build/Mac/UnrealPak/Development/UnrealPak.link Total build time: 3.18 seconds Command /Users/mike/Development////UnrealEngine/Engine/Build/BatchFiles/Mac/Build.sh failed with exit code 5

I've checked permissions and ownership of the folders and they all belong to my user (I've down a chown -R just in case).

Any input would be great appreciated! :-)

Product Version: UE 4.12
Tags:
more ▼

asked Jul 14 '16 at 05:51 AM in Packaging & Deployment

avatar image

MikeNielsen
26 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think I figured this out! I thought I had checked all permissions, but UnrealPak binary was set to Read only on all permissions. chmod'ing this seems to have done the trick so far.

more ▼

answered Jul 15 '16 at 05:17 PM

avatar image

MikeNielsen
26 2 3

avatar image MikeNielsen Jul 16 '16 at 06:30 AM

It seems like a lot of files are read-only causing problems when building.

Is this intended from the distribution?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question