x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issue with level opening

So I have tried creating the main menu using this example shown here -> https://docs.unrealengine.com/latest/INT/Engine/UMG/QuickStart/4/index.html, but when I clicked on the button nothing happened, it just stayed there. All other keys are working fine.

I even tried doing this, but still the same problem. alt text

I have also tried adding this in DefaultEngine.ini

 [AlwaysCookMaps]
  +Map=/Game/FirstPersonBP/Maps/FirstPersonExampleMap

Product Version: UE 4.12
Tags:
level.jpg (113.7 kB)
more ▼

asked Jul 18 '16 at 03:01 AM in Using UE4

avatar image

akshay
25 2 4 5

avatar image fabianu Jul 19 '16 at 01:54 AM

The version in the docs and the example with the "Make Literal Name" node both work for me. I can not reproduce your error.

avatar image akshay Jul 19 '16 at 02:42 AM

I have tried it, here is the project link could you test it on your end?

https://github.com/akshaybabloo/UnrealEngine_4_Notes

Thanks.

avatar image fabianu Jul 19 '16 at 02:45 AM

sure but tomorrow. (already 5am here)

avatar image akshay Jul 19 '16 at 02:46 AM

Yes. Please.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok I could find your error now.

The main problem is, that you open your MainMenu Widget in the FirstPersonExampleMap and not in another Level.

To show you what realy happens when you start the game is the following:

  1. It loads the FirstPersonExampleMap map. This is configured in Project Settings > Maps & Modes > Default Maps > Editor Startup Map.

  2. It loads the MainMenu widget as configured in the FirstPersonExampleMap Level Blueprint (with the BeginPlay Event).

  3. When you now click the Play Button it loads the FirstPersonExampleMap again. This reload of the map triggers the BeginPlay Event of the Level Blueprint again executing the step 2. from above again.

This loop makes it look like nothing happings but this is incorrect. To fix this you have to create a new Level i.e. MainMenuLevel. Configure this as startup map in the project settings and let it load the MainMenu widget and remove the MainMenu widget from the FirstPersonExampleMap. Then everything will work as you intend it.

The creation of a main menu level is documented in the first page of the tutorial you linked in your question: https://docs.unrealengine.com/latest/INT/Engine/UMG/QuickStart/1/index.html

greetings

more ▼

answered Jul 19 '16 at 02:55 PM

avatar image

fabianu
498 12 9 34

avatar image akshay Jul 20 '16 at 12:05 AM

Thank you for pointing that out, I did follow that but forgot to take the level into consideration.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question