x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Low FPS / Crashes on Android game

I just finished working on my game (im a student, not a full time developer), it works perfectly fine in the editor. However when i package it for android (ETC1) and try to play it in my phone/ other phones it either crashes or runes in low fps, until crashing eventually. 1. is it because of the engine version i am using? (4.10 instead of 4.12)

  1. is it because i am using particle effects? (the starter content ones, explosion and sparks). because the game 100% crashes whenever the explosion is spawned. or it might just be that it just tips it over to the crashing side and might not be the cause of it.

  2. no objects in the scene have the "cast shadows" option enabled, yet in the android game ONLY when run on the phone itself i can see shadows cast by the "railings" on the floor. it happens on all devices i have tested it on, for some reason it is still rendering shadows.

  3. Does having rather complex blueprints running actually effect the performance of the device? like having multiple timers running (my game has like 4 "set timer by event nodes" running for multiple purposes). does it have drastic effect in performance? or is it overshadowed by the graphical and rendering part.

  4. i use the "add obb in apk" option when packaging the product, since the game itself is not that big and the resultant apk is under the 100bm limit.

  5. i also use "create compressed packages" does that somehow decrease performance? since it literally halves the size of the apk for me.

  6. also i have noticed that the rendering quality is really bad when i play it on the phone as compared to the pc, is that normal? (everything looks "pixelated") or do most products look Identical when packaged as windows as compared to packaged to android?

i really worked hard on this game for about 2-3 weeks and dont want all this to go waste. it does run smoothly when i package it for windows or try to play it in the editor, but it has really bad fps/crashes everytime. would really appreciate some advice on how to i go about solving this issue, as ive tried but failed on my own. Do feel free to ask me if you need any more information on the matter, thanks for your time!

here are some relevant screen shots: alt text alt text alt text alt text alt text

Product Version: UE 4.10
Tags:
222.png (157.6 kB)
capture.png (61.5 kB)
fffff.png (54.4 kB)
wdffff.png (50.1 kB)
wdwdwdw.png (143.3 kB)
more ▼

asked Jul 18 '16 at 06:12 AM in Packaging & Deployment

avatar image

N4RJ4M
22 12 9 12

avatar image Samantha Sutton ♦♦ STAFF Jul 19 '16 at 08:11 PM

N4RJ4M,

Please review the following documentation links, as they'll help you optimize your game for Android:

I will also need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

Thanks!

avatar image N4RJ4M Jul 20 '16 at 06:00 AM

i attached the phone to the computer (its shows when i run the command "adb devices" in command prompt on my computer)

usb debugging is enabled on my device

i open moniter.bat, it opens up command prompt that closses shortly after then this window pops up alt text

i dont see anything relevant here so im sure i am doing something wrong

is there some intermediate step that i have missed?

i have never tried to get logs or anything of that sort before so sorry for my newbieness :P where exactly do i find these logs? if they are maybe already saved somewhere in the background? ive tried to do some searches on forums and google about getting these logs but all kinda left me at a dead end

lklklk.png (28.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 20 '16 at 08:48 PM

I would highly suggest looking over this guide, it seems like you're having trouble with your Java.

Once you've gotten passed this error, try to obtain the logcat files for me again, thank you! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey N4RJ4M,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Jul 25 '16 at 08:38 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question