x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaged Game Crashes when Loading Next Level

My VR game seems to be working fine when run through the editor. When I package the game, it works at first but as I skip through different levels it has a tendency to crash while loading the next level. Certain play-throughs crash at different levels so I'm not sure why this is happening.

I'm using Oculus DK2 and Media Textures if either of those might be the culprit. CrashReportClient.exe also displays several of these errors before running the packaged game the first time. But after that it no longer displays them:

The instruction at 0x00007FFC87AE00EA referenced memory at 0x00007FFC87AE00E8. The memory could not be written. OK to terminate the program, CANCEL to debug the program.

Here is my Crash Report:

MachineId:804FF16A48065EF732929393D437DD08

EpicAccountId:27a38c4966514977a6c57ddecb1ed59b

Access violation - code c0000005 (first/second chance not available)

apothecaryAR_inter!TBaseMulticastDelegate::Broadcast() apothecaryAR_inter!TGraphTask::ExecuteTask() apothecaryAR_inter!FNamedTaskThread::ProcessTasksNamedThread() apothecaryAR_inter!FNamedTaskThread::ProcessTasksUntilQuit() apothecaryAR_inter!FTaskGraphImplementation::WaitUntilTasksComplete() apothecaryAR_inter!FPhysScene::WaitPhysScenes() apothecaryAR_inter!FPhysScene::EnsureCollisionTreeIsBuilt() apothecaryAR_inter!UWorld::FlushLevelStreaming() apothecaryAR_inter!UEngine::LoadMap() apothecaryAR_inter!UEngine::Browse() apothecaryAR_inter!UEngine::TickWorldTravel() apothecaryAR_inter!UGameEngine::Tick() apothecaryAR_inter!FEngineLoop::Tick() apothecaryAR_inter!GuardedMain() apothecaryAR_inter!GuardedMainWrapper() apothecaryAR_inter!WinMain() apothecaryAR_inter!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

I've attached my DXDiag info and diagnostic files directory. Diagnostic Files DXDiag

Any help is greatly appreciated!

Product Version: UE 4.12
Tags:
more ▼

asked Jul 20 '16 at 05:34 PM in Bug Reports

avatar image

HidingGlass
98 6 14 18

avatar image Rudy Q ♦♦ STAFF Jul 21 '16 at 02:44 PM

Hello Matochai,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved?

avatar image HidingGlass Jul 21 '16 at 05:05 PM

Hi Rudy, thanks so much for helping me look into this.

  1. The problem only seems to occur in this project. And only in the packaged version of the game.

  2. As far as reproducing the issue, I've been trying to introduce the assets one at a time back into a clean scene to see what triggers a crash but unfortunately I haven't found it yet and it takes some time because I need to package each time. I can provide the packaged game if that would help.

Also, I can sometimes switch levels without the error ever occurring. It seems almost random!

  1. Here is the general layout for my levelBlueprint where I believe (if the error is blueprint related), the problem should be. The top network initializes the level (closes other media players to prevent impacting performance and opening the media player that is acting as the skybox for a VR360 video) and the bottom switches to the new level when the video is done playing:

alt text

This is the second method for moving to the next level (like a skip function). While both methods cause a crash, this method seems like it triggers it more often.

alt text

avatar image Rudy Q ♦♦ STAFF Jul 25 '16 at 02:21 PM

Hello Matochai,

Would it be possible for you to provide the project that is having issues? Could you also include a reliable set of steps to reproduce the crash within the provided project?

avatar image Rudy Q ♦♦ STAFF Jul 29 '16 at 03:10 PM

Hello Matochai,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

avatar image HidingGlass Aug 02 '16 at 06:44 PM

Hi Rudy, Sorry I was away at the SIGGRAPH conference last week and was not at my computer. I narrowed the issue down to a single asset and created a test level that crashes consistently when packaged.

Within "CrashTest_NextLevel" you can open "PACKAGES\01\WindowsNoEditor\CrashTest_NextLevel.exe". The game consists of 3 levels that you can rotate between by looking at the "Move To #" floating text. A loading wheel widget is triggered and once it goes all the way around the game should move to the next level. I made my ray-trace visible so that you can tell when you're triggering the asset. When I go to rotate between levels, it often crashes (though sometimes it takes rotating between levels a few times).

The "N" key will also move to the next level but this method does not seem to crash the game. "Esc" will quit.

The game also seems to run fine when playing in the editor and only crashes in the packaged version. I also see that the widget asset is "experimental" and not currently supported. Is this likely the culprit?

CrashTest_NextLevel.zip

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Matochai,

I was able to reproduce this issue on our end with the project provided. I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use this link provided for future updates. Thank you for your time and information.

Link: https://issues.unrealengine.com/issue/UE-34107

Make it a great day

more ▼

answered Aug 02 '16 at 09:16 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 523

avatar image HidingGlass Sep 01 '16 at 03:47 PM

Hi, It seems this issue was shelved because they could not reproduce it (though it seemed you were able to Rudy).

I'm still running into this same error and crash so I was wondering if there was anything else I could do that might put this back on the radar. Thanks

avatar image Rudy Q ♦♦ STAFF Sep 01 '16 at 04:48 PM

Hello Matochai,

To clarify, cannot reproduce in this case means that the issue mentioned in this thread appears to be resolved internally and that it should be available in a later release of the engine.

avatar image HidingGlass Sep 01 '16 at 05:57 PM

Oh great! Thanks for clearing that up.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question