x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] [Bug?] Whenever I move this happens...

Whenever I move the skeletal mesh seems to fox around the edges. Is there a fix for this or is it just a bug with the engine that is being worked on?

alt text

And this ONLY happens when I push a key to move.

Product Version: Not Selected
Tags:
why.png (857.6 kB)
more ▼

asked Mar 11 '14 at 02:46 AM in Blueprint Scripting

avatar image

ue4-archive ♦♦ STAFF
50.1k 3672 2002 9129

avatar image SteveKouts Sep 15 '14 at 01:24 AM

Yep this happens with mine too and didnt before. It happens while animating too and looks terrible. Must be a bug in the latest version. Please fix

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Oct 03 '14 at 05:08 PM by Doug E for the following reason:

Beta question


4 answers: sort voted first

Hello,

This is a question from the beta version of the engine. We are marking this answered for tracking purposes. If you are experiencing an issue similar to this please post a new question.

Thank you.

more ▼

answered Oct 03 '14 at 05:07 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This looks to be an artifact due to motion blur. We'll take a look here and see what can be done to improve it.

more ▼

answered Mar 11 '14 at 02:46 AM

avatar image

ue4-archive ♦♦ STAFF
50.1k 3672 2002 9129

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

How to turn motion blur off to remove the artefact?

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

You can set MotionBlurAmount to 0 in your post process volume.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

I tried setting the Global PostProcessVolume to Amount (off) and 0 and nothing changes, still blurring the player mesh when it moves in PIE (in the sidescroller game project).

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

I also turned off the Disabled flag for the global post process but that makes no difference either.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

You want to leave Amount (the influence of the volume) at 1. You want to set only MotionBlurAmount to 0

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

Thanks Nick, that answer got me there. As I see it, what works is to highlight the Global PostProcess in Scene Outliner then in the Details panel, in the section Motion Blur set Amount as ticked and set its value to 1.0 and set Max as ticked and its value to 0.0. This gets rid of the fuzzy transparent edges on my character in SideScroller anyhow.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

For me it occurs for the same mesh in SideScroller but not in 3rdPerson.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

In the same Global PostProcess as Motion Blur settings, there's a MISC settings section, and in there if I set the AA Method as FXAA I get much much nicer looking edges than in Temporal (the default). Why is that? Setting None makes mesh edges pixelly, but I can see how they would be.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Chris,

We are looking into your issue. To clarify, by "move the skeletal mesh" you mean you are using the translation gizmo to move it in the editor or are you playing in editor when this happens only? Any additional details for reproducing this issue would help greatly.

-Alexander

more ▼

answered Mar 11 '14 at 02:46 AM

avatar image

ue4-archive ♦♦ STAFF
50.1k 3672 2002 9129

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

No this happens when i am playing the game. Moving the character with the wsad keys/playing the game. i haven't done anything but make a new blueprint side scroll game and change the skeletal mesh. It has been happening since the first build i got of UE4. I was hoping that it would be fixed in the update but its still here.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

I got the same thing on my 2 GPUs (GTX 470 and HD4850) with both the build 1627304 and 1711197. It happens in every project when playing (in viewport/in game, especially noticeable with the ShooterGame and the player's weapon).

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

yep same i have a gtx460m

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

I added a skeletal mesh to replace the cube in MyCharacter blueprint in the details section. Then PIE the sidescroller default scene, and I get the same blurry/transparent edges of the mesh when moving.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM +

yep this needs fixing!

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:46 AM

second that!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This looks like an artifact due to temporal AA. You see this only when dragging the mesh around in the viewport, right? When playing an animation you shouldn't notice it.

more ▼

answered Mar 11 '14 at 02:46 AM

avatar image

ue4-archive ♦♦ STAFF
50.1k 3672 2002 9129

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question