x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Linux] UE4 Editor black window

Hi!

I want to try new android x86 support so I download and build latest UE release (4.12.5) from GitHub on my Gentoo Linux.

But when I launch UE4Editor I got absolutely black windows. But it's seems like anything else works fine because it react on click on plasec where should be close/minimize buttons and display tooltipes (black too) on buttons mouse hover.

Here my launch logs. Here screencast.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 22 '16 at 08:48 AM in Installation & Setup

avatar image

Yukarin
1 3 5

avatar image Doug E ♦♦ STAFF Jul 22 '16 at 02:00 PM

Hey Yukarin-

Since the editor window is still responsive it appears to just be a visual issue. Can you try updating your video drivers to see if that helps.

avatar image Yukarin Jul 22 '16 at 07:44 PM

I use latest open source video drivers (Linux kernel 4.6.4 and mesa 12.0.1). These drivers work fine for me in many other apps (including some 3D app like games or Blender).

avatar image Doug E ♦♦ STAFF Jul 25 '16 at 05:17 PM

If you're using the latest open source drivers, it may be that support for those drivers has not been implemented. Please try the most recent stable drivers for your video card.

avatar image Yukarin Jul 26 '16 at 07:14 AM

But I already use most recent stable driver, latest stable kernel from kernel.org is 4.6.4 and I use it, latest stable mesa from mesa3d.org is 12.0.1 and I use it too.

avatar image Doug E ♦♦ STAFF Jul 26 '16 at 03:08 PM

Sometimes running Open Source graphics drivers can cause issues or crashes when launching the engine. Please switch to the Binary Release for NVidia / AMD (whichever type of card you're using), then try running again.

avatar image Yukarin Jul 28 '16 at 04:12 PM

I still have black window on Ubuntu 16.04 with latest (15.12) AMD Catalyst driver.

avatar image Doug E ♦♦ STAFF Jul 28 '16 at 05:34 PM

I'm unable to find reference to Catalyst drivers, are you referring to 15.12 Crimson drivers? I also saw that 15.12 is an OpenGL 4.5 driver. There are some known issues using ShaderModel5 on Linux. This may be the cause if you are passing -opengl4 as an argument when launching the engine. If that is the case try launching without -opengl4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Yukarin-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers

Doug Wilson

more ▼

answered Aug 05 '16 at 06:37 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question