x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Default subobject exists

I have a problem , after building my project, when I try to launch it in the editor, it crashes and an error is shown:

 Fatal error: [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 3418] 
 Default subobject CameraComponent Text already exists for KeypadBase /Script/Project.Default__KeypadBase.

This, I think , Is connected to another error: I need about 3 rebuilds and 2 crashes for new code (for example UPROPERTY added to class) to show in Editor. It seems like rebuilding project creates new files without deleting old ones and editor tries to load both of them (?). I tried cleaning it, does anyone knows what else can I do?

Product Version: UE 4.12
Tags:
more ▼

asked Jul 22 '16 at 10:59 AM in C++ Programming

avatar image

Nevermore
227 33 35 49

avatar image Stickman550 Jun 17 '18 at 11:11 PM

I'm using 4.15.3 and getting this same error. I tried creating some child actors in a subclass I made. I ended up crashing the editor for this very reason. I think it was because I accidentally used the same name on two of the child actors. I tried renaming them and rebuilding, but the editor still wont open. It keeps giving me the same error. I removed the subclasses and any BP associated with them from my code and my project, but the editor still will not open. I'm not entirely sure whats going on or how to fix it either. I'm kind of in the same boat here.

avatar image Stickman550 Jun 17 '18 at 11:39 PM

After messing around with my project, I finally got it to open in the editor again by deleting the contents of the "Intermediate" folder and then regenerating the visual studio project files. (right click on the Unreal Engine Project File > Generate Visual Studio project files. Don't forget to rebuild your solution in visual studio afterwards).

Be sure to back up the contents in your Config file before trying this or you may lose all your editor settings. (DefaultEngine.ini & DefaultInput.ini)

avatar image staticvoidlol Jun 22 '18 at 10:28 AM

You can add this comment as an answer and mark it as resolved.

avatar image falconblade Sep 28 '18 at 05:32 PM

This happened to me when I copied one mesh to create a new mesh and forgot to rename the DefaultSubObject as shown below:

 HandMesh = CreateDefaultSubobject<USkeletalMeshComponent>(TEXT("Mesh"));
 ArmMesh = CreateDefaultSubobject<USkeletalMeshComponent>(TEXT("Mesh"));

Once I made their names unique, everything worked:

 HandMesh = CreateDefaultSubobject<USkeletalMeshComponent>(TEXT("Hand Mesh"));
 ArmMesh = CreateDefaultSubobject<USkeletalMeshComponent>(TEXT("Arm Mesh"));

Simple after seeing the issue but not apparent at first because the project compiles fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question