x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Remote iOS packaging failing with exitcode 5

Hello, I am having trouble to compile codes for IOS using remote build. It was successful when I tried it about month ago and now I can't even build blank c++ project with 4.12.5 version. There is always compilation error near end of process.

I tried to do clean reinstall and compile of both Windows and Mac engines, 3 times... Still not working and I have no idea what is the issue...

error: AutomationToolLauncher exiting with ExitCode=5

(both Installations are in root/C UE4 folder with permissions set, certificates and provisions are matching = colored green)

Here is the log: http://www.filedropper.com/blankc

Thank you

Product Version: UE 4.12
Tags:
more ▼

asked Jul 22 '16 at 11:59 AM in Bug Reports

avatar image

Skylonxe
81 4 5 12

avatar image Samantha Sutton ♦♦ STAFF Jul 22 '16 at 06:45 PM

Skylonxe,

Do you have your remote build set up in the project settings? Sometimes they don't save, or they'll not be saved when a hotfix is implemented.

avatar image Skylonxe Jul 22 '16 at 07:04 PM

Hello Samantha, thank you for quick response. As you can see, i have working connection to mac machine and compilation works good until it reaches almost end. I am testing this in newly created blank cpp and newly compiled engines for both mac and windows, so updates should not matter.

avatar image Samantha Sutton ♦♦ STAFF Jul 22 '16 at 08:16 PM

Skylonxe,

Have you tried deleting your Intermediate and Saved folders from your project file, rebuilding your project and trying to package again?

If that does not work, try the following in MS-DOS

  rmdir /S /Q Binaries
  rmdir /S /Q Build
  rmdir /S /Q Intermediate
  rmdir /S /Q Saved
  
  rem BlankC.uproject

Please upload new logs once you've gotten further. If you're unsure about the script in MS-DOS, feel free to create a copy of your project before moving forward.

Thank you!

avatar image Skylonxe Jul 23 '16 at 04:03 AM

I did it all but same error. It could not help because I posted that previous log right after first launch of new editor and new project.

But here is new log:

http://www.filedropper.com/blankc_1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Works after updating XCode to latest version (7.3).

That's ridiculous because I had to use old version of XCode to build engine (can't find Answer Hub question about that issue now) and new version to build the project. Who knows, maybe 4.12.5 would build even engine with new XCode.

more ▼

answered Jul 23 '16 at 11:42 AM

avatar image

Skylonxe
81 4 5 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question