x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Component visualisation resets when not selected

I've created a custom form of spline, that simply inherits from spline component and adds a handful of variables. I've made an editor module and a component visualiser for this custom component and it all seems to work fine. However, the issue comes when I DON'T have the component selected, the visualiser seems to revert or reset to a default state when it's not selected. Regardless of how many keys I have on the spline and where I position them, when not selected, it simply shows 2 keys 100 units away from each other as splines are when they are first put in.

Obviously this issue doesn't happen with normal splines, but the odd thing is my custom spline inherits from spline, and my visualiser is literally a copy paste (exactly) of the spline visualiser, again adding 3 commands for the right click menu; changing the GetEditedSpline() to return the type of my custom spline; and 3 lines in the visualiser:

 if ((KeyIdx == 0 && SplineComp->bDeadStart) ||
      (KeyIdx == NumSegments && SplineComp->bDeadEnd))
 {
     KeyColor = (KeyColor.ReinterpretAsLinear() * FLinearColor(1, 0.5f, 0.5f, 1)).ToFColor(true);
 }

Here's a gif of the issue:

alt text

Does anyone have any ideas why this might be? I've tried searching the source code for any references to the spline visualisation that might be getting added/changed that I haven't done with my own, but to no avail.

Product Version: UE 4.12
Tags:
splineissue.gif (1.1 MB)
more ▼

asked Jul 22 '16 at 12:15 PM in C++ Programming

avatar image

Ungalyant
102 11 15 23

avatar image KnightArchitects Mar 01 '17 at 05:23 PM

I'm having a similar problem with my own custom visualiser. Did you ever find out why this was happening?

avatar image Ungalyant Apr 04 '17 at 04:35 PM

I'm sorry to say I didn't. I no longer have the issue, but that could have been from any number of tweaks I made to the code, or by simply updating engine version. Certainly whenever it was fixed, I wasn't directly attempting to do it, so it'd be very hard for me to note the point at which it stopped being a problem :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question