x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I cannot see my objects that I created in BluePrint Class.

Hi, I am very new to UE4. In fact very new to game design. I just started on unreal engine and I have following issue. I created a blueprint class and added few actors to it. Everything went well but on one day I cannot see any of my objects (at least not how they are supposed to appear) in my viewport window of blueprint class. Please see screenshot below. I may be too stupid and did something dumb but, I am not sure how to get out of this view. Rest of my blueprints are fine. I tried to zoom out and rotate the view but all I see is a blue line. I cannot see any of my objects. alt textPlease help.

Product Version: UE 4.12
Tags:
capture.jpg (72.2 kB)
more ▼

asked Jul 23 '16 at 05:50 PM in Using UE4

avatar image

Vigetta448
8 2 4 4

avatar image NoobsDeSroobs Jul 23 '16 at 05:52 PM

First, check the scale of each object. Make sure that they are all 1. Check that each part has visibility set to true(is checked).

avatar image Vigetta448 Jul 23 '16 at 10:41 PM

Scale are 1 in the blueprint. I dont think we can toggle visibility in blueprint for objects can we? I may be wrong I am very new to UE4

avatar image NoobsDeSroobs Jul 24 '16 at 03:24 AM

They are called components, not objects. Objects are a different thing. Anyways, yes you can. First and foremost, click on each item and do what the answer below is saying. Try moving the camera around as you might be inside or far away from the components.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi there, (just to help you with terminology: Actors are within the Level, Components are within the Actor)

If you have lost your component out of sight in the viewport, you can focus it (centered and zoomed in) with the shortcut F. Just select the component in the Components Tab, make sure to click into the Viewport and hit F.

You can also hide Components as well: Select your Component and check the "Visible" Property if it is set to true (for visibility in editor viewport), and if "Hidden in Game" is set to false (for visibility in game).

Level Viewport supports focusing and visiblity as well. Just select the Actor in the World Outliner and hit F or check the properties for visibility in editor / game.

Since you say you are new to UE, you are probably flooded by tutorials already. If you are looking for short and compact tutorials without exhausting overhead, I would recommend you these tutorials from the UE channel: https://www.youtube.com/playlist?list=PLZlv_N0_O1gaCL2XjKluO7N2Pmmw9pvhE

hth :) Marooney

more ▼

answered Jul 24 '16 at 12:28 AM

avatar image

Marooney
886 36 8 36

avatar image NoobsDeSroobs Jul 24 '16 at 03:21 AM

Off topic, but what does hth mean? I presume it is an abbreviation, but I can not extrapolate it into anything meaningful.

avatar image Vigetta448 Jul 24 '16 at 04:03 AM

Hi Marooney, Thank you for your time. My problem is not in the viewport of editor. I am having issue with view port within the blueprint class. Focus with hotkey F will not work inside blue print.

avatar image Marooney Jul 24 '16 at 10:51 AM

As I said, Components are within the Blueprint Viewport and not within the Level Viewport :) hotkey F works in every Viewport. The problem within Blueprints is just that you need to make sure to click into the Viewport before hitting F. I am not sure if that would solve your problem but at least it centers and zooms your cam onto the component that might still be invisible due to scaling or visibility settings :)

avatar image Marooney Jul 24 '16 at 10:58 AM

Hey. hth means "Hope That Helps". At least this is the "official definition" when you look this up. In another context it means HowTheHell XD I am sure there are some other nasty meanings if someone wants to create or find them ^^ If someone punches me into the interface I probably need to check the definition again :) So hth :)

avatar image Vigetta448 Jul 25 '16 at 06:22 PM

I am still stuck in same position. Please someone help me.

avatar image Marooney Jul 25 '16 at 06:44 PM

Would it be a problem if you just delete the missing Components and place them in again, with a littebit of re-wiring?

avatar image Marooney Jul 27 '16 at 10:31 AM

Since your question is still not marked as resolved, how is it going?

avatar image Vexar Aug 09 '18 at 09:21 PM

I have one blue print where my perspective camera is very far from the assembled models.

If I look at the thumbnails for every object used including the blueprint they look right is there some way that I could written over the default camera starting spot or a way to override it?

It is annoying to have to pick the model every time I open it and select the wrong thing from so far away hit F and then pick the item i want. I know I can select the object in the component but I have a ton of objects including all the lights, emitters, etc.

Another off topic question is the 2d emitter sprite for all emitters has been in this view port for almost 2 years. They show up in the other view ports fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I figured this out finally for my object it might help other people. For me the reason the camera was so far away from the blueprint object was that I had an emitter with a giant bounding box, you cannot see this in the bp editor but it takes this volume into account when deciding how far to push the camera back from the object. If you go through each emitter and check the bounding box setting it might be the cause. Once I reset the bounding volume on the emitter the camera move forward to the proper location.

Reason this is confusing is that the thumbnail image looks fine.

more ▼

answered Aug 14 '18 at 08:48 PM

avatar image

Vexar
94 5 11 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Inside the BluePrint : 1) Go to Viewport TAB 2) Click on a Component, 3) Then Click in the viewport , 4) Then Hit F (focus) , and BAM! everything is back! At least that worked for me after 2 days of searching, remaking my complex blueprint and end with an out of focus problem grrrrrrrr. The key part is: DON'T FORGET TO CLICK IN THE VIEWPORT AFTER YOU SELECTED A COMPONENT, then hit F , if you don't click in the viewport (on a grey raster area) , F will not work.

more ▼

answered Aug 26 '18 at 09:23 AM

avatar image

Mikevandoorne
1 1 3

avatar image Marooney Aug 26 '18 at 11:48 AM

Oh, might have been easier with my answer above (from 2016) :) "Just select the component in the Components Tab, make sure to click into the Viewport and hit F."

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question