x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do i get proper scale from 3ds max to unreal engine?

Hi, I've done 2 architectural projects in unreal engine so far but both times I had to scale up all the models by a large amount I use AutoCAD and inches real world scale for my architectural visualizations but when I import them into unreal engine the models are tiny for some reason how can I fix this so I don't have to keep doing that every time, it makes no sense and making me not want to use the engine. Also I use the starting first person mode maybe the character is to tall by default I don't know.

Product Version: UE 4.11
Tags:
more ▼

asked Jul 23 '16 at 11:16 PM in Using UE4

avatar image

ScronnyLanks
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi ScronnyLanks,

Unreal Engine 4 uses centimeters as it's scale size. Make sure you make this adjustment in AutoCAD on Export or when creating your assets.

1 cm = 1 Unreal Unit

This documentation page has some useful information for Asset Creation for UE4 as well. https://docs.unrealengine.com/latest/INT/Engine/Content/ContentStandards/index.html

I hope this helps.

Tim

more ▼

answered Jul 25 '16 at 01:25 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image ScronnyLanks Jul 25 '16 at 03:06 PM

I don't really understand I have a big project already complete using inches so its kind of to late for the adjustment in AutoCAD is there a way to have it import to unreal engine to the right size now without rescaling everything?

avatar image Tim Hobson ♦♦ STAFF Jul 25 '16 at 08:42 PM

In your FBX Export settings under Units set it to Centimeters. This will convert the scene to centimeters and should work for your proper scale. I did a test with this with a 6' tall box exported as inches vs centimeters in comparison to the default character skeletal mesh in the editor which is slightly taller than 6 foot and all checked out.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yay i had the same problem importing from 3dsmax i switched it to export in centimeters and boom perfect.

more ▼

answered Sep 27 '17 at 11:02 AM

avatar image

rolle817
18 6 9 12

avatar image blinkimage Dec 06 '17 at 03:53 PM

This doesn't work for me. I created a 1m cube in 3dsmax2016, wiuth system unit scale in meters (this we have done for over 15 years).

I export an FBX telling it to convert to CM.

Import into UE4, and the box is tiny! alt text alt text alt text alt text

scaleproblema.jpg (186.8 kB)
scaleproblemb.jpg (86.7 kB)
scaleproblemc.jpg (98.7 kB)
scaleproblemd.jpg (111.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question