Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Generate chunks" = packaging fail

I was testing the generate chunks because I don't really like my pak file bigger than 2 gb, but if I try to package with any asset that inst on chunk 0 I get this error:

MainFrameActions: Packaging (Windows (32-bit)): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure) MainFrameActions: Packaging (Windows (32-bit)): Domain_ProcessExit MainFrameActions: Packaging (Windows (32-bit)): copying UAT log files... MainFrameActions: Packaging (Windows (32-bit)): BUILD FAILED PackagingResults:Error: Error Unknown Cook Failure

I tested too on a empty project (first person template) and the error are the same. If I set the asset back to chunk 0 again the project packages with no problem.

Maybe I'm doing something wrong?

Product Version: UE 4.12
more ▼

asked Jul 24 '16 at 08:44 AM in Packaging & Deployment

avatar image

218 18 26 36

avatar image CQ Aug 12 '16 at 09:15 AM

Have you solved this problem yet?I have now exactly faced the same problem.

avatar image Samantha Sutton ♦♦ STAFF Aug 15 '16 at 08:31 PM

If you're having trouble with this as well, please try my last response with the guided visuals or post your own AnswerHub for additional assistance.

Thank you! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Gustavorios2,

Could you please upload your full output log and also provide me screenshots of how you've set this up in your project launcher profile?


more ▼

answered Jul 25 '16 at 07:35 PM

avatar image gustavorios2 Jul 25 '16 at 08:44 PM

Hi Samantha thanks for answering

video of the steps: https://www.youtube.com/watch?v=qRs70UO7Ov0

log http://pastebin.com/raw/RdY4cHWX

avatar image gustavorios2 Jul 26 '16 at 07:55 PM

don't really know if its a bug or I'm missing something. But its something I need to solve before release to steam

avatar image Samantha Sutton ♦♦ STAFF Jul 28 '16 at 09:00 PM

Have you tried using Unreal Frontend?

Make sure that you're setting up the Chunk settings within Project Settings > Project > Packaging under Packaging. Here is an example of mine:

Example 1

Once that is set up like you want it to be for your project, go ahead and open the Project Launcher. Create a Custom Launch Profile and use the following screenshots as guided examples for you:

Example 2

Example 3

Please do not forget the quotes around your filepath, otherwise you'll run into a very vague error:


Once the packaging process is successful, it'll be nested in the Builds folder under the platform you've packaged for, which in my case was Windows and Android_ETC2.

avatar image gustavorios2 Jul 28 '16 at 10:14 PM

I haven't used frontend because It looks like it wont generate a win32. I'll try setting the path and settings as you say and return soon

avatar image gustavorios2 Jul 29 '16 at 06:37 AM

Tried to package using unrealfrontend but the problem persists.

I don’t really need streaming of chunks over the web. I just want to split my huge .pak file in 2 or 3 files. =(

alt text

avatar image Samantha Sutton ♦♦ STAFF Jul 29 '16 at 08:53 PM


The examples I provided before were for a guideline on how to get that to work. Now, I went ahead and adjusted my pak a bit and verified that this set up is currently working properly on my machine.

Example 1

Example 2

This packaged successfully and here is my result folder:

Example 3

Does this set up cause you any trouble? If so, please upload the full error output logs as a .txt file with your next reply.


avatar image Mootjuh Sep 30 '16 at 09:25 AM

I am stuck with this too. Tried packaging for win64 using chunks using the settings that were posted in the pictures. No luck.

Here's my log.

link text

avatar image Samantha Sutton ♦♦ STAFF Sep 30 '16 at 05:44 PM

Please submit your question in a new thread on AnswerHub. Be sure to test in 4.13.1 and give us those results as well.


avatar image Mootjuh Sep 30 '16 at 06:50 PM

Thanks, I've posted my question here.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question