x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.12.5 CrashReportClient wont open upon crash

That's it. No matter what I do, no matter what I try I just can't fix it. The CrashReportClient won't work and It's a pain to work without it. I saw that it was a bug with the github source built engine and got fixed on 4.12.4, but I'm using the Epic Games Launcher build and 4.12.5. I tried EVERYTHING, fresh install of everything related to the engine, visual studio, etc. Today I formatted my PC as a last resort. Still not working! It's not my project as it doesn't work with any project. I even tried with "debug crash" console command.

Here's my CrashReportClient log, it's basically useless, there's no error in the log, it does fine until for no apparent reason it just exits.

 Log file open, 07/25/16 00:16:10
 LogPlatformFile: Not using cached read wrapper
 LogInit:Display: RandInit(-1752685619) SRandInit(-1752685618).
 LogTaskGraph: Started task graph with 3 named threads and 6 total threads with 1 sets of task threads.
 LogInit: Version: 4.12.5-3039270+++UE4+Release-4.12
 LogInit: API Version: 2992821
 LogInit: Net Version: 3039270
 LogInit: Compiled (64-bit): Jul  6 2016 09:20:55
 LogInit: Compiled with Visual C++: 19.00.23026.00
 LogInit: Build Configuration: Shipping
 LogInit: Branch Name: ++UE4+Release-4.12
 LogInit: Command line: "..\..\..\Engine\Binaries/Win64/CrashReportClient.exe"  -AppName=UE4-CastleFight -CrashGUID=UE4CC-Windows-615F1AD14D59CCE0116CE2BA8FBFAF41_0000 -DebugSymbols=..\..\..\Engine\Intermediate\Symbols
 LogInit: Base directory: D:/Epic Games/4.12/Engine/Binaries/Win64/
 LogInit: Installed Engine Build: 1
 LogInit: Presizing for max 100000 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
 LogInit: Object subsystem initialized
 [2016.07.25-03.16.10:144][  0]LogInit: Computer: STORMCROW
 [2016.07.25-03.16.10:144][  0]LogInit: User: Franco
 [2016.07.25-03.16.10:144][  0]LogInit: CPU Page size=65536, Cores=4
 [2016.07.25-03.16.10:144][  0]LogInit: High frequency timer resolution =3.914067 MHz
 [2016.07.25-03.16.10:144][  0]LogMemory: Memory total: Physical=15.9GB (16GB approx)
 [2016.07.25-03.16.10:144][  0]LogMemory: Platform Memory Stats for Windows
 [2016.07.25-03.16.10:144][  0]LogMemory: Process Physical Memory: 24.04 MB used, 24.04 MB peak
 [2016.07.25-03.16.10:144][  0]LogMemory: Process Virtual Memory: 50.56 MB used, 50.56 MB peak
 [2016.07.25-03.16.10:144][  0]LogMemory: Physical Memory: 3481.90 MB used, 16304.66 MB total
 [2016.07.25-03.16.10:144][  0]LogMemory: Virtual Memory: 203.74 MB used, 134217728.00 MB total
 [2016.07.25-03.16.10:147][  0]LogTextLocalizationManager: No specific translations for ('es-AR') exist, so ('es') translations will be used.
 [2016.07.25-03.16.10:153][  0]LogPackageLocalizationCache: Processed 2 localized package path(s) for 2 prioritized culture(s) in 0.000090 seconds
 [2016.07.25-03.16.10:153][  0]CrashReportClientLog: CrashReportReceiverIP: http://crashreporter.epicgames.com:57005
 [2016.07.25-03.16.10:153][  0]CrashReportClientLog: DataRouterUrl: https://datarouter-public-service-prod06.ol.epicgames.com/datarouter/api/v1/public/data
 [2016.07.25-03.16.10:154][  0]LogCrashDebugHelper: DepotName: //UE4/Release-4.12
 [2016.07.25-03.16.10:154][  0]LogCrashDebugHelper: BuiltFromCL: 3039270
 [2016.07.25-03.16.10:154][  0]LogCrashDebugHelper: EngineVersion: 4.12.5-3039270+++UE4+Release-4.12
 [2016.07.25-03.16.10:154][  0]LogCrashDebugHelper:Warning: CrashDebugHelperConfig invalid
 [2016.07.25-03.16.10:154][  0]LogCrashDebugHelper:Warning: PDB Cache disabled
 [2016.07.25-03.16.10:154][  0]LogExit: Preparing to exit.
 [2016.07.25-03.16.10:154][  0]LogObj: Freed 0b from 0 cluster array pools.
 [2016.07.25-03.16.10:154][  0]LogExit: Object subsystem successfully closed.
 [2016.07.25-03.16.10:154][  0]LogModuleManager: Shutting down and abandoning module CrashDebugHelper (2)
 [2016.07.25-03.16.10:154][  0]LogModuleManager: Shutting down and abandoning module CoreUObject (1)
 [2016.07.25-03.16.10:154][  0]LogExit: Exiting.
 [2016.07.25-03.16.10:154][  0]Log file closed, 07/25/16 00:16:10


My friend was using this build and working in the same project on windows 8.1 and his crash report client worked fine. Today he installed windows 10 and still works for him.

It's super frustrating. IT MUST BE A BUG, please help me with this.

Thank you

Product Version: UE 4.12
Tags:
more ▼

asked Jul 25 '16 at 03:38 AM in Bug Reports

avatar image

Sveitar
973 8 23 26

avatar image Sean L ♦♦ STAFF Jul 25 '16 at 01:00 PM

Hello,

The first thing I'd like you to try would be to use Windows Event Viewer to detail the reason for the Crash Reporter window not opening.

First, cause the engine to crash using the 'debug crash' (without the quotes) command in the command line, which you can open up while in the editor by pressing the ~ key.

Then, have a look at this wiki and follow the steps so you can provide me with the logs: https://wiki.unrealengine.com/Windows_Event_Viewer

Thanks!

avatar image Sveitar Jul 25 '16 at 07:47 PM

Hi Sean, thank you for your answer! I tried this yesterday and I'm trying again right now and when I crash the engine there is no entry added to the event viewer. I see some entries but no one coincides with the editor crashes. Here's the event registry saved following the wiki instructions, if you want to take a look.

link text

events.zip (4.5 kB)
avatar image Sveitar Jul 25 '16 at 07:52 PM

In case it's useful I'm on intel z170 platform (i7 6700k, asus maximus viii ranger), as I have a friend running windows 10 on h97 and his crash report client is working just fine. Actually right now the only difference between his setup and mine is the chipset. As we both have nvidia 900 series graphics cards and i7 processors, and both systems are fresh installs of windows 10 pro with just the necessary dependencies to run the engine.

avatar image Sean L ♦♦ STAFF Jul 26 '16 at 12:09 PM

Did you use debug crash to crash your editor before you provided the event viewer logs? This will unfortunately not work as it only captures if the app crashed in a manner that caused it to crash for Windows.

avatar image Sveitar Jul 26 '16 at 09:12 PM

I did exactly as you told me:

"First, cause the engine to crash using the 'debug crash' (without the quotes) command in the command line, which you can open up while in the editor by pressing the ~ key.

Then, have a look at this wiki and follow the steps so you can provide me with the logs"

avatar image Sveitar Jul 26 '16 at 09:15 PM

Anyways, if there's no error log for the CrashReportClient, It means that the CrashReportClient is not crashing and is exiting cleanly

avatar image Sveitar Jul 28 '16 at 09:19 AM

I´m still trying to fix this. Do you have another idea?

avatar image Sean L ♦♦ STAFF Jul 28 '16 at 03:07 PM

Try downloading a source build from github. Once you have this, build the CrashReporterClient project in Visual Studio and let me know if you get a crash reporter window after performing a debug crash in that version.

Thanks!

avatar image Sveitar Jul 28 '16 at 07:45 PM

Hi Sean, I tried exactly that last night just for curiosity. I still don't get the CrashReportClient. I even uninstalled the launcher previously so there's no conflict with the version selection, etc. I compiled the CrashReportClient and it's executed but never shown, and again the log it appears to be exiting cleanly but without reason.

avatar image Sveitar Jul 28 '16 at 11:56 PM

Here is the source build CrashReportClient log:

link text

avatar image Sveitar Jul 29 '16 at 12:34 AM

I tried again with 4.11.2 from launcher and it's not working either. It seems that the launcher CrashReportClient was updated with 4.12.

avatar image Sean L ♦♦ STAFF Aug 04 '16 at 05:59 PM

Apologies for the delay. We are currently investigating this issue, and we'll respond as soon as we have additional information.

Thanks for your patience.

avatar image Sveitar Aug 04 '16 at 06:03 PM

Thank you Sean. There's no need to apologize. I understand that this is an exceptional case and it's difficult to find what's causing the problem. As far as I know we are just 2 people having this issue. Make me know if you need anything to proceed.

avatar image ChrisWood STAFF Aug 10 '16 at 09:35 AM

Try this...

  • Generate a new crash

  • You're getting no CRC window but you're getting a CRC log, right?

  • Examine the command line in the CRC log

  • Look in your Windows Error Report queue folder

  • If your crash is there, open the runtime-xml file and check that the values match your command line: GameName matches -AppName=, CrashGUID matches -CrashGUID=

There may be a problem here with WER settings. Windows can save these reports to different locations and there are settings in the registry that determine exactly how it behaves.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

Take a look at the post linked below and see if the accepted answer will resolve your issue:

https://answers.unrealengine.com/questions/453736/engine-crashes-instantly-what-to-do.html

Have a great day!

more ▼

answered Aug 15 '16 at 01:24 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

avatar image Sveitar Aug 15 '16 at 06:49 PM

OMG this worked! One of the things I always do when installing windows 10 is disabling everything related to privacy. This was one of those things I disabled!! I didn't know about this side effect. Thank you very much for the research!!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question