x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Set Actor Tick Enabled' not working after spawning

UPDATE: It works only when called from Begin Play event, but not from other events or functions executed after spawning!

If you try to disable actor ticking by 'Set Actor Tick Enabled' set to FALSE, it doesn't do anything, actors still ticks. You can test it by e.g. printing a strings from its Event Tick.

Also, looks like this bug happened before: https://answers.unrealengine.com/questions/312656/enabledisable-tick-in-blueprints.html

Product Version: UE 4.12
Tags:
more ▼

asked Jul 25 '16 at 11:36 PM in Bug Reports

avatar image

Slavq
2k 157 153 210

avatar image Adam Davis STAFF Jul 26 '16 at 02:06 PM

Hi Slavq,

I attempted this on my end and it seems to be working as intended. What steps can I take to reproduce this on my end in a clean, blank project with no additional content?

avatar image Slavq Jul 26 '16 at 03:11 PM

I've created a simple demo project and attached it here. DEMO PROJECT

The 'TestActor' blueprint is commented to demonstrate the bug.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Slavq,

The error you are experiencing is because the actor has not been fully initialized when you run the function. Try adding a delay between the spawn and the function, this stopped the tick on my end.

more ▼

answered Jul 26 '16 at 05:11 PM

avatar image Slavq Jul 26 '16 at 06:07 PM

Ah, so that's the case! It worked, thank you!

avatar image Ryan Darcey May 18 '17 at 08:11 PM

Dang! This caught me, too. Dirty little gotcha. Had some serious perf implications!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question