x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to create DLC properly?

Hi,

I'm trying to create a simple DLC for a couple of days now, and I'm having issues with this. What I'm trying to achieve is package a project, without DLC content available in it, and then create DLC .pak file and add it to original project. But it seems that it doesn't work this way.

What I've already tried:

  1. Create Simple project

  2. Create plugin named MyDLC

  3. Create packaging profile for game: FullGame profile

  4. Create packaging profile for DLC: DLC profile

  5. Start FullGame profile, then DLC profile

Now there comes the issue. If I open the game with current settings from StagedBuilds directory, I can open map from DLC, without copying any files (that shouldn't be possible because there shouldn't be DLC content in the project).

If I select Map in FullGame profile I cannot open DLC maps from StagedBuild but even if I copy the proper pak, I still can't do this. I get following error: open MapDLC error

I'm copying pak into ProjectName/Content/Paks in the StagedBuilds directory.

I tried this on 4.11, 4.12 and git release branch from yesterday (for git branch I also included the bugfix from this topic: https://answers.unrealengine.com/questions/415690/load-asset-async-from-dlc-pak-file-failed.html) without any luck.

So my question is, what is wrong and how can I make it work? Maybe I'm missing something trivial?

I'm also including game project with DLC plugin for 4.12.5 Launcher version: DLC412 project

Product Version: UE 4.12
Tags:
more ▼

asked Jul 27 '16 at 11:03 AM in Packaging & Deployment

avatar image

Mateusz.Wiech
66 7 8 19

avatar image Samantha Sutton ♦♦ STAFF Aug 01 '16 at 08:07 PM

Mateusz,

Thank you so much for providing such a detailed post. So we've gotten through your steps, but we need to know a couple things:

  • How are you getting from the game running with the base map and switching it to the DLC map?

  • What set up are you using exactly? There doesn't seem to be one in the example project that you provided.

During our repro, we made the main title set "Map" as the "Game Default Map" in project settings, and gave the DLC a separate map "DLCMap" so we were able to distinguish them. We also set "Map" to cook with FullGame profile, and "DLCMap" cooks with the DLC profile.

Looking forward to hearing back from you, thanks!

avatar image Mateusz.Wiech Aug 01 '16 at 08:36 PM

Hi Samantha,

I'm using the simple open command for both maps. 'open Map' for normal map and 'open MapDLC' for DLC map.

What do you mean by setup? I made screens of every profile, they can be viewed by clicking the links in my post. I will provide everything that is necessary if it's not enough.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Mateusz,

Unfortunately the problem isn't trivial, as you had hoped. Samantha and I have reproduced your results and have determined there to be a bug in the 4.11 and 4.12 releases of Unreal. In 4.13 theses issues do not occur[1] and we were able to successfully load the DLC content.

We're still investigating the cause. Our hunch is that there may be a problem with how the DLC pak files' content path's are being resolved in the engine, which would be a non-trivial issue.

If we discover a workaround, a code change or some other remedy to get you past this, I will be sure to update the thread.

[1] - In 4.13 we discovered a different bug related to DLC which has been there all along. The checkbox to "Include Engine Content" for DLC has inverted packaging logic. It either properly cooks but improperly does not package, or it properly does not cook but improperly tries to package.

Cheers,

Jonathan

more ▼

answered Aug 04 '16 at 03:04 PM

avatar image

NaturalPanic STAFF
141 4 5 11

avatar image Mateusz.Wiech Aug 04 '16 at 03:13 PM

Hi Patrick,

Good you were able to reproduce this and it doesn't occur in 4.13. Wish you good luck with finding solution for all the bugs connected with DLC packaging. I will be waiting for any further response from you.

Mateusz

avatar image Mateusz.Wiech Sep 03 '16 at 10:24 PM

I just want to confirm that in version 4.13 this problem is fixed.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question