x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Can't find file for asset. /Script/CableComponent" on 4.12

After upgrading my project from 4.10 to 4.12, everytime I open it I get the error "Can't find file for asset. /Script/CableComponent"

It works if I just go to my hookshot blueprint, readd the Cable Component and redo it's conections but it's a pain to do that everytime I reopen my project.

Tried adding CableComponent to the dependency modules on my Build.cs and the I'm still getting the same error. Any ideas?

Thanks.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 27 '16 at 02:29 PM in Blueprint Scripting

avatar image

homembarata
127 6 9 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Fixed it.

If anyone is having a similar problem, I had to open "C:\Program Files\Epic Games\4.12\Engine\Plugins\Runtime\CableComponent\CableComponent.uplugin" and change the LoadingPhase from "Default" to "PreDefault"

I believe that makes the plugin load up earlier.

more ▼

answered Aug 01 '16 at 11:41 AM

avatar image

homembarata
127 6 9 19

avatar image Johat Jan 17 '17 at 01:03 PM

Just want to say thanks for figuring this out! This was driving me crazy yesterday. This fix works fine in the latest version of the editor too.

This is still an issue in 4.14(.3) -- it'd be great if Epic could have this fixed off the bat so we don't have to tweak built in components.

(In my case, I had a blueprint inheriting from CableActor that was becoming invalid every time I loaded. I'd create a new blueprint to replace it and whenever I next loaded, just found that this new one was broken now [but the first was fine].)

avatar image ja0335 Dec 13 '17 at 06:26 PM

Thanks a lot!

avatar image kunal.jathal Jan 10 '19 at 11:10 PM

thanks!! worked for me too

avatar image EspritElf May 24 '19 at 11:20 AM

This worked for me for the unreal wiki AI Utility plugin and 4.22.

avatar image DenKuzn Jun 13 '19 at 05:41 AM

I had some problem with Niagara. Have error: Can't find file '/Script/NiagaraEditor'.

Changed all boot options from Default to PreDefault. The problem is resolved. Thx.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey,

Sometimes when you upgrade your project the blueprints gets "dirty", I think this might be your problem.
Try the "Fix up redirectors" by rightclicking in your content browser.

There are also some other ways to force Unreal to clean it but this one is the easiest.

Hope this helps :)
Elias

more ▼

answered Jul 27 '16 at 03:09 PM

avatar image

PasteDog
1.2k 24 16 53

avatar image homembarata Jul 27 '16 at 04:08 PM

Thanks but I've tried it and I'm still getting the same error. :/

avatar image PasteDog Jul 28 '16 at 09:13 AM

If you duplicate the hookshot BP, does it also give this error?

avatar image homembarata Jul 28 '16 at 10:20 AM

Well, if I duplicate it, the new object comes with the same error. I even tried recreating the hookshot BP from scratch and I still get the same error when I close and reopen Unreal.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question