x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Components stuck in absolute transform

Hello, after upgrading to 4.12, all my splines components have been set to absolute.

alt text

Here you can see where the Pivot is for one spline, along with the spline component itself (and all the others). They are all in 0,0,0 world position, and moving the pivot no longer moves their component.

I've tried things like this in the constructor, beginplay, etc.

 Spline->AttachToComponent(RootComponent, FAttachmentTransformRules::KeepRelativeTransform);
 Spline->SetRelativeLocation(FVector(30, 0, -100));
 Spline->SetAbsolute(false, false, false);

But no matter what I do, they're 100% absolute. That code even moves them to 30,0,-100 world position.

Any ideas how to fix this?

Product Version: UE 4.12
Tags:
more ▼

asked Jul 27 '16 at 05:48 PM in C++ Programming

avatar image

Juice-Tin
154 35 36 45

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Fixed, for anyone else with a similar problem:

 Spline->SetMobility(EComponentMobility::Static);

This was set elsewhere in the code, with all the splinemesh components attaching to the spline component. It worked finr in 4.11, but in 4.12 unreal no longer likes spline being static, and everything breaks.

Solution was to attach the static splinemeshes elsewhere and to leave spline as movable.

more ▼

answered Jul 29 '16 at 04:06 PM

avatar image

Juice-Tin
154 35 36 45

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question