Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.8.3] Why does GetUnfocusedVolumeMultiplier() not work?

I tried to call FApp::GetUnfocusedVolumeMultiplier(); after setting the UnfocusedVolumeMultiplier config so it would update without needing to restart the game. But it did not work.

The code Im using first sets the config via: GConfig->SetFloat(TEXT("Audio"), TEXT("UnfocusedVolumeMultiplier"), TempMulti, GEngineIni);

Then calls FApp::GetUnfocusedVolumeMultiplier(); which is the only publicly accessible means for 4.8.3 to set the UnfocusedVolumeMultiplier variable in FApp. (That I know of)

I know that the config is changing properly because if I exit the game and restart, the configs are properly updated and it works once restarted.(Meaning: it plays while unfocused based on the config)

But the call to FApp::GetUnfocusedVolumeMultiplier(); doesn't seem to do anything. Is there a way to immediately update the UnfocusedVolumeMultiplier in 4.8.3?

Product Version: UE 4.8
more ▼

asked Jul 29 '16 at 12:35 AM in C++ Programming

avatar image

423 47 52 76

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question