x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG - Missing Objects in UE4 4.11.2

I came across this bug that whenever I open up the UMG Editor I see nothing at all but whenever I play/run the game it perfectly works fine. Like I can't edit anything inside the UMG Editor itself.

This only happens to one of my UMG Objects but the other files are working fine. I hope this issue gets fixed in the upcoming hot fix of UE4.12

alt text

alt text

Product Version: UE 4.12
Tags:
bug_01.png (210.8 kB)
bug_02.png (651.0 kB)
more ▼

asked Jul 29 '16 at 07:31 AM in Bug Reports

avatar image

AlsonEntuna
81 2 5 8

avatar image Rudy Q ♦♦ STAFF Jul 29 '16 at 03:28 PM

Hello AlsonEntuna,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any other blueprints/widgets that may be involved with this issue.

  4. I noticed that you have a few of your widgets to be hidden in the designer tab (the eye with the slash in it next to the widget name in the hierarchy), could you try unhiding these and let me know if this resolves your issue?

  5. I saw that you have somethings set to "Size to content", could you run through these to make sure that your widget are not just small?

avatar image AlsonEntuna Aug 01 '16 at 08:43 AM

Hi Rudy sorry for the late reply.

  1. I can't actually reproduce it it just suddenly happened in my current project. I guess you just have to disable all the elements in the UMG editor

  2. ----

  3. So far this is the only blueprint that is doing this weird thing as of the moment.

  4. I already tried unhiding them all but still no signs of fixes on my part.

  5. The font of some of the Texts in my UMG Editor are already set to 74. Also already tried out to increase the font size to let's say 100 but still no fix.

avatar image Rudy Q ♦♦ STAFF Aug 01 '16 at 06:10 PM

Could you provide a zipped down copy of your project via drop box or google drive so that I could take a closer look at your widgets?

avatar image AlsonEntuna Aug 02 '16 at 01:37 AM

I could send the repository link in your email. Could I have your email so that I could send it to you. This project is a bit confidential. Thanks

avatar image keyle Aug 02 '16 at 04:24 AM

From your editor screenshot, if you look in the hierarchy panel, you will see "eye" icons to the right of the elements.

They appeared crossed off. Click the eye to make them appear.

HTH

avatar image AlsonEntuna Aug 02 '16 at 04:29 AM

I already tried that one but it still doesn't get me anything. If you check the first image I sent, Title is already visible but it doesn't give me anything.

avatar image keyle Aug 02 '16 at 05:02 AM

Actually the canvas is tiny. See that blob of 9 dots top left? Scale that up, the stuff is in there I believe.

avatar image AlsonEntuna Aug 02 '16 at 05:53 AM

I actually tried increasing the size of the rect transform of the UI that I'm editing but it really doesn't do anything. I'm not sure why I only encounter this in one UMG. All the other UMGs are working perfectly fine actually.

avatar image Rudy Q ♦♦ STAFF Aug 04 '16 at 02:09 PM

Hello AlsonEntuna,

If you would like to provide a copy of the project privately, you can do so by providing a link to a zipped down version of your project via a dropbox or google drive link in a private message to me on the forums.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello AlsonEntuna,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks

more ▼

answered Aug 08 '16 at 03:14 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image AlsonEntuna Aug 12 '16 at 12:33 PM

Hi there Rudy,

This one maybe a glitch or just a minor bug but I suggest you look it in whether other users may recreate this one. Thanks for the support! Keep it up Epic Games

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question