x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Bug: "Any Key" event strange compile

Hello, I added this code on my Character for pressed keys tracking

alt text

And after I put "key get display name" my blueprint compiles successfully but compile sign never goes to "Good to go" anymore and stays "dirty, needs to recompile" even tho everything works just fine.

alt text

I tried this event on empty Character and sign goes green. Can you help me to solve this problem? If needed I can send project.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 31 '16 at 12:49 AM in Bug Reports

avatar image

Xukapy
138 13 18 30

avatar image Xukapy Jul 31 '16 at 01:03 PM

Maybe this bug not even connected to "Key Get Display Name" node. Someone had same problem?

avatar image Rudy Q ♦♦ STAFF Aug 01 '16 at 02:37 PM

Hello Xukapy,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide any additional screen shots of blueprints/settings that may be need for reproducing this issue?

avatar image Xukapy Aug 01 '16 at 02:43 PM
  1. As I said I tried it in same project on new Character blueprint and it compiles fine and sign goes "Goodtogo"

  2. Not really, it just this event on screenshot that makes button stays "dirty" though blueprint compiles successful. Not really event but "get key display name" node. If I make (Any key -> Print string) without anything sign goes "GoodToGo"

  3. My character pretty heavy blueprinted. Better if I send whole project I guess but it on 4.12.4

avatar image Rudy Q ♦♦ STAFF Aug 01 '16 at 05:39 PM

If you would like to provide your project you can do so by providing a link to a zipped down version of your project via dropbox or google drive.

avatar image Xukapy Aug 01 '16 at 06:28 PM

Ok, give me your pm please

avatar image Rudy Q ♦♦ STAFF Aug 01 '16 at 06:37 PM

You can send me the link via a private message on the forums.

avatar image Xukapy Aug 01 '16 at 10:16 PM

Sent it...

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

After looking through your project I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provide a link to the public tracker. Please feel free to visit the provided link for future updates. Thank you for your time and information.

Link: https://issues.unrealengine.com/issue/UE-34068

Make it a great day

more ▼

answered Aug 02 '16 at 02:46 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Xukapy Aug 02 '16 at 03:10 PM

Thanks, please change steps to reproduce a little bit

7 Notice that the blueprint will no longer compile

Blueprint IS compiling, its just the sign that stays "dirty"

avatar image DG Gage Feb 24 '17 at 04:59 AM

Experiencing this now in 4.15 with Key is Gamepad within my controller BP. Oddly, creating a new controller BP and doing it there works fine. Also works in my player BP. So it seems to have happened within a particular BP. I am very early in the project, so there's not a ton of content in it. It also has been compiling just fine otherwise. I can migrate everything over to a new BP, but I'm guessing you guys might wanna take a look.

UPDATE: So I was able to duplicate the BP and insert the Key is Gamepad node and it worked. Extra weird.

UPDATE: It ended up happening again anyway, even after compiling with that node and showing that it was compiled. Now it always shows dirty for compile status. It still works; it's just showing the wrong icon for dirty I guess? It behaves as if it is compiled.

So it seems the bug is still around, but more of an aesthetic issue than a dev breaker.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question