x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Normals in Unreal not smoothing the model?

Hey! My team have been working on some models and materials etc. and I thought that normals looked pretty good in UE4...until my modeller showed me this. The bolts are smoothed in Unity (via the normals), but in UE4 they are still really edgy. Anyone know why? I have the same problem with my other models, that use the same material (I cant attach another photo, so you can inspect the material setup in the comment section of this question).

alt text

alt text

Product Version: Not Selected
Tags:
unityshield.jpg (276.0 kB)
shield.png (515.6 kB)
more ▼

asked May 20 '14 at 06:53 PM in Rendering

avatar image

Borzi
174 43 39 48

avatar image Borzi May 20 '14 at 06:54 PM

Heres the Material for anyone who might need it! Its pretty basic.

alt text

metallicshader.png (93.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Borzi -

I have confirmed that it is your smoothing groups. I took you model into Maya and redid the smoothing groups on your model and it imported correctly. Here is a screenshot: (The original import with no smoothing groups is shown in the distance.)

alt text

Hope that helps you guys out -

Eric Ketchum

smoothing.jpg (153.0 kB)
more ▼

answered May 21 '14 at 04:13 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Borzi May 21 '14 at 07:17 PM

Thanks for the effort man! We are using Blender, will we still be able to correct it (use these smoothing groups)?

avatar image Lovecraft_K ♦♦ STAFF May 21 '14 at 07:22 PM

Hey Borzi -

Yes, you should be able to, try look **here** for information

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Borzi -

It looks like your normal is on the model, but the smoothing groups were not imported into UE4. I would have to see the FBX (or original model file) for the model to know for certain but check to make sure your model is smoothed correctly in your modeling program then re-import the asset into UE4.

Let me know if this fixes your problem or you are still having problems -

Eric Ketchum

more ▼

answered May 20 '14 at 09:23 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Borzi May 21 '14 at 05:19 AM

Alright thank you! Will look into it and get back at you.

Edit: If I sent you a FXB file, would you be able to take a look at it?

avatar image Lovecraft_K ♦♦ STAFF May 21 '14 at 12:58 PM

Yes, I could look into it for you. Just upload the FBX if you want to keep it private let me know.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question