x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Decals on Android do not work. What is a alternative Solution?

Hi, I am doing a small Paintball Shooter for mobile devices. The impact of the color bullet should be a blur of color. For that i used decals on the desktop version of the game, but for Android they are not showing up.

A similar question was asked 2 years ago, but with no answer. Thank you for your help and excuse my English :-D.

PS: I am a newbie in ue4 and this is my first post in the forum! <3

Product Version: UE 4.12
Tags:
more ▼

asked Aug 01 '16 at 09:25 AM in Using UE4

avatar image

tbockmair
14 5 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort oldest

Forgive me if this doesn't help but... Here's a part of s post I thought may be relevant to your situation;

I got mine working by following the instructions above, plus a few missing/commented elsewhere steps (see below)

Unreal 4, build 4.7.5:

While your decal-broken project is open, open Project Settings: and change these under 'Rendering': https://answers.unrealengine.com/storage/attachments/33368-dbuffer%20(2).jpg

Save & close your project

Search for 'DefaultEngine.ini' in your projects folder (not 'BaseEngine.ini' which was likely the old name) & open it.

Scroll down, look for '[/Script/Engine.RendererSettings]' & change these (may not be required) FROM: r.EarlyZPass=2 r.EarlyZPassMovable=TRUE r.DBuffer=TRUE TO: r.EarlyZPass=2 r.EarlyZPassMovable=1 r.DBuffer=1

Reopen your project

Open your decal's Decal Material and change 'Decal Blend Mode' to any of the 'DBuffer...' options [I used 'DBuffer Translucent Color']

DONE! - it should now show up properly!

more ▼

answered Aug 01 '16 at 09:38 AM

avatar image

TroJanVirus
83 2 4 10

avatar image tbockmair Aug 01 '16 at 10:44 AM

Thank you for your answer! I cant open the image (error 403: Access to the specified resource () has been forbidden.) but I think you changed the following 3 in Project Settings: - checkbox for DBuffer Decals - Early Z-pass in "Opaque and masked meshes" - checkbox Movables in early Z-pass

I changed the statements (TRUE into 1) in the DefaultEngine.ini and used the same DBuffer Translucent Color. It is working in the Editor but not on my Android phone.

Did it worked on your Phone? :s

avatar image tbockmair Aug 01 '16 at 11:13 AM

EDIT: I changed the Decal Blend Mode to "Translucent" instead of "DBuffer Translucent Color". Now I see my decals! I choosed the DBuffer to display the decals in any lights, but maybe it is not supported on Android.

avatar image TroJanVirus Aug 01 '16 at 11:59 AM

Glad you can see them now! That's some good progress. I'm not sure about decals being picky about lighting so I guess it's a trial-and-error thing really. I would suggest looking at some Android building rules to make sure all of your project will build correctly. Don't forget to check if you have any errors as well after building.

avatar image JackP STAFF Aug 02 '16 at 09:36 AM

Hi, because mobile uses a forward renderer instead of the deferred renderer we use on PC and console, we support only translucent, additive and modulated blend modes on mobile decals. For the same reason, only unlit decals are supported.

avatar image inji8 Nov 10 '18 at 03:09 PM

I can't see your image linked. plz update your image or just typing for "rendering" option :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ran into same issue, on mobile the decals did not work, the easy solution for me was to simply enable MobileHDR in the rendering settings and that solved my problem. My settings for decal material are simply "Translucent, Translucent". Then there is also this video that explains what to do for different decal rendering situations: https://www.youtube.com/watch?v=Xe1WKQMRguY In the video description check the link to their website as well.

more ▼

answered May 18 '19 at 08:30 PM

avatar image

Jurif
632 27 15 45

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question