x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Warning CreateExport: Failed to load Outer for resource ... for many blueprints

Hi,

we just run into a problem of one of my team mates machine. On that machine we get the warning "Warning CreateExport: Failed to load Outer for resource ..." a lot (<800) in many blueprints. And after that the editor is crashing most times. I copied his project folder over to my machine and there is everything running fine. We reinstalled the launcher and unreal as well as completely deleted and force synced the whole project from P4. But nothing is helping. On all other team machines in our team the project is running fine.

After deleting and resynching the whole project I get once the error: "Failed to import 'C:/Program Files (x86)/Epic Games/4.12/FeaturePacks/StarterContent.upack'. Failed to create asset '/Game/StarterContent'" But unreal is installed with starter content.

One artist is completely blocked atm. please help.

Kindly Martin

Product Version: UE 4.12
Tags:
more ▼

asked Aug 02 '16 at 03:05 PM in Using UE4

avatar image

MartinSE
71 4 9 17

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

We were able to fix the problem by deleting the unreal cache folder.

The unreal cache folder is located here: %userprofile%\AppData\Local\UnrealEngine

We still have no idea what caused the problem.

more ▼

answered Aug 03 '16 at 08:43 AM

avatar image

MartinSE
71 4 9 17

avatar image MartinSE Aug 08 '16 at 03:23 PM

The problem showed up again and we found out it is enough to delete the %userprofile%\AppData\Local\UnrealEngine\4.12 folder.

avatar image acxsasx Oct 28 '16 at 02:51 PM

I just updated to 4.13.2. I am getting the same error but on a much smaller test project based the first person shooter demo. I tried deleting the 4.13 folder as you suggested to no avail.

avatar image acxsasx Oct 28 '16 at 02:55 PM

I deleted the 4.14 and the Common directory. That fixed it.

avatar image eden_kee Feb 27 '17 at 07:03 AM

Has anyone tried this in a Mac system?

avatar image samnater Jul 02 '17 at 10:42 PM

Worked perfectly for me. Thank you!

avatar image Vexar Jan 04 '18 at 02:17 AM

I am getting to happen in 4.18.1 a lot for some reason. Not sure what is causing the data corruption but it is nasty. The editor won't load and the Blueprint class breaks. I thought it might be caused by having 4.17 and 4.18 open at the same time with the same asset being used by two different projects.

(comments are locked)
10|2000 characters needed characters left

I am getting the exact same error with 4.19.2. I purchased a new laptop so that I could work on the project while I am traveling, as well as show off what we have completed so far to potential investors and publishers. Today, I downloaded all of the new files from our Perforce server to my laptop after checking everything in on my desktop and I started getting this same error on the laptop.

alt text

I have tried all of the suggestions to fix the issue, but none of them work. Any additional help with this would be most appreciated.

more ▼

answered Sep 26 '18 at 07:28 AM

avatar image

FlankGaming
1

(comments are locked)
10|2000 characters needed characters left

You can try the following (make a backup of your project folder before or have it in source control). This helped me with UE 4.19.2:

  1. Delete all derived folders & files inside the Unreal project folder (leave only Config, Content & Source folders, and .uproject file).

  2. Re-open Unreal - from the launcher or .uproject.

  3. Generate your IDE project files (Win: via Explorer context menu; Mac: Via Unreal)

Best, Tim

more ▼

answered Oct 09 '18 at 04:21 PM

avatar image

timdhoffmann
1 1 1

(comments are locked)
10|2000 characters needed characters left

SO i just ran into this problem in the past week or so, we are using git hub and doing all of our source control through it. We are also using git LFS. I played around with a couple of different things to get past this error, including the help ideas suggested above. I can't give a concrete step by step solution to the problem. But I can give the things i did to ultimately get past this problem.

  • Delete the %userprofile%\AppData\Local\UnrealEngine (as suggested by Martin)

  • Delete the internal files like Timdhoffmann suggested (I deleted only the Saved and Intermediate folders)

  • Run the following git command

    git filter-branch --force --index-filter 'git rm --cached --ignore-unmatch Content/* Config/* Build/* Import/*' --prune-empty --tag-name-filter cat -- --all

At this point i repulled my repo, and things started to work.

I believe that this essentially purges all the references within your git delta history (i could be wrong if anyone can correct). SO THE WARNING HERE is if you don't want to lose all of those references within your git history don't do this. This effects the references in all of the repo's branches.

The rabbit hole I went down to solve this problem: https://community.gamedev.tv/t/project-still-broken-since-refactor/59468 https://help.github.com/articles/removing-files-from-git-large-file-storage/

more ▼

answered Oct 19 '18 at 01:38 AM

avatar image

RUWD
3 4 7 8

(comments are locked)
10|2000 characters needed characters left

I'm having the same issue, for me the problem was that the level I was loading had previously contained a blueprint that no longer existed.

more ▼

answered Dec 12 '18 at 12:39 AM

avatar image

IlllIl
44 4 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question