x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

shipping build crash win64

hi all,

I use Unreal 4.12.5. my project is 99.99% C++. Visually I have an empty floor and 2 bots, one being the player and the other one AI. I'm running heavy logic and logging so in development mode the frame rate stutters. I wanted to see if the shipping build would be more performant.

I successfully compiled a Windows 64-bit shipping build. When I run it the app just crashes. there are some entries in the Windows application log, and a Windows crash report file. The actual extension of the report file is .wer but I couldn't upload it, so I renamed it to .txt.

This is a sample.txt of an entry from Windows application log

I already tried verifying and reinstalling UE4, restarting etc. to no avail. same behavior with Windows 32. same behavior on another computer.

Please let me know.

Thanks!

link text

link text

Product Version: UE 4.12
Tags:
report.txt (15.3 kB)
sample.txt (768 B)
more ▼

asked Aug 04 '16 at 01:14 AM in Packaging & Deployment

avatar image

room101
11 1 5 8

avatar image Sean L ♦♦ STAFF Aug 04 '16 at 01:58 PM

Hello,

  • Are you getting a Crash Reporter window at all?

  • Does this occur if you package it for development?

  • Have you been able to reproduce this in a clean project at all? If so, please provide a detailed list of repro steps.

avatar image room101 Aug 04 '16 at 06:42 PM

hi Sean, thank you very much for your reply!

•Are you getting a Crash Reporter window at all?

no, I do not.

•Does this occur if you package it for development?

it occurs for any combination of win32/64 with shipping/development/debug

•Have you been able to reproduce this in a clean project at all? If so, please provide a detailed list of repro steps.

a clean project works fine. I'm currently trying to rebuild it from scratch in smaller increments, but honestly I have dozens of classes in various degrees of interconnection, so I don't know if the smaller increments approach is achievable. I have about 10 UE4 actors and objects, and about 40 classes almost exclusively for AI and combat. Initially I used heavy reflection, but yesterday I spent it re-factoring my code to avoid it, unfortunately to no avail

my system is currently Windows 10 64-bit, it's a clean build, less than two months with only a handful of software installed almost exclusively for UE4 development. besides the logs I already uploaded, I don't think I have anything else to report...

Thanks!

avatar image Sean L ♦♦ STAFF Aug 05 '16 at 01:23 PM

Hello,

Since you're unable to reproduce it in a clean project, and you are not getting a Crash Reporter window, would you be able to zip up the project, upload it to dropbox, and provide me with a link so I can test it on our end?

You can PM me the link through the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

After further investigation, I was unable to get any useful information from the logs, or determine what is causing the project to crash. What I'd recommend, as you suggested earlier, is attempting to slowly rebuild it from scratch. Although this process can be tedious, it will allow you to narrow down the cause of the crash. If you are able to determine the code that is causing the crash, feel free to reopen this thread and I'll be more than happy to look into the issue further. On the same note, if you are able to provide any additional information that you feel will be helpful in reproducing this in a clean project, don't hesitate to comment on this thread.

Have a great day!

more ▼

answered Aug 10 '16 at 01:57 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image room101 Aug 10 '16 at 04:14 PM

Thank you Sean! I'll update here if any new info becomes available.

avatar image room101 Aug 15 '16 at 03:37 AM

hi Sean, I finally discovered the culprit.

When I possess my pawn, I create some default items on it, using some code that eventually ends with

UBlueprint* itemBlueprint = LoadBlueprintFromPath(FName(*sItem));

ADA2UE4Item* oItem = oCreature->GetWorld()->SpawnActor(itemBlueprint->GeneratedClass); //this line is the culprit

I double checked and the blueprint is being loaded fine. I also tried to create the item when I press a key, just in case my character's not fully initialized, but I had the same problem. I even tried AActor* oItem = oCreature->GetWorld()->SpawnActor(itemBlueprint->GeneratedClass); with same result :(

Any clue why outside PIE has this issue, or is there a better alternative to spawn actors?

Thanks!

avatar image Sean L ♦♦ STAFF Aug 16 '16 at 12:33 PM

I'm not sure why this would cause a crash outside of PIE, other than the possibility that something you are passing into the function does not exist in the world yet (depending on when you are calling the function, some items may not have been initialized as you mentioned).

However, here is the documentation for Spawning Actors: https://docs.unrealengine.com/latest/INT/Programming/UnrealArchitecture/Actors/Spawning/

Give one of those methods a shot and see if you're having the same error.

avatar image room101 Aug 16 '16 at 06:03 PM

hi Sean, thank you very much for your reply!

I managed to fix this specific issue by using the method described here

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question