x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Are there settings that could cause a normal map not to load when using "Launch Game" or "Play as Standalone"?

I am trying to figure out why, my normal maps on my character show up just fine when I play the game from within the UE4 Editor, however, whenever I use "Launch Game", the normal maps aren't loading. I have tried different sizes and formats, so I don't think it's the texture itself. But I can't figure out why it would just not load the normal map at all. Does anyone have any insight into this?

Edit: a tiling normal map is showing up, but my main normal map is the one that isn't working. Also, when playing the game from in Editor as Standalone, it doesn't show up either.

Product Version: UE 4.9
Tags:
more ▼

asked Aug 04 '16 at 01:01 AM in Packaging & Deployment

avatar image

Yayrenay
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

Try packaging the game out instead. I'm suspecting that the assets are not being cooked, which is why they are not being displayed when you Launch Game.

You can also add specific asset directories to cook under Edit->Project Settings->Packaging and expand the dropdown under the Packaging Section. Here you'll find Additional Asset Directories to Cook, and you can add the directory containing your assets.

more ▼

answered Aug 04 '16 at 02:01 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image Yayrenay Aug 05 '16 at 04:07 PM

It turns out that it was actually to do with the mipmap and texturegroup settings in the texture, for anyone who might have the same issue popping up. Thank you for your response and help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question