x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

view mode hotkeys don't work half the time.

The problem is that all the hotkeys to change view modes (ie, alt-4=lit, alt3=unlit, alt-6=lightmap, etc) don't work. I've had this problem in every version of UE4 I've ever tried, where sometimes the hotkeys work and sometimes they don't and I can't find what causes it. Sometimes rebooting the editor will fix it and sometimes it won't. The actual commands themselves do work of course, you just have to go use the menu to press those buttons and that's too slow. I switch view modes all the time, a good percentage of it's use is that what i'm looking at is too dark for whatever reason ranging from I haven't lit that area yet, there's out of date shadows, etc, and i can't tell what in the world is going on in front of me so I normally switch to unlit view to be able to see the problem and start working on it. Unfortunately that's not working right this second and I've seen this problem so many times that I figured I'd better get off my butt and report it. :)

Thanks! -seneca

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 05 '16 at 11:04 PM in Bug Reports

avatar image

indigosm
46 3 7 14

avatar image Steve Hardister ♦♦ STAFF Aug 08 '16 at 04:47 PM

Hi indigosm,

Please provide your System specs so we can test on a similar machine.

Thanks,

Steve H.

avatar image indigosm Aug 08 '16 at 04:57 PM

I've had this problem occur many times on every machine I've ever used so I don't think that's related. The only similarity any of the machines had was that they were all running windows.. (win7/win8/win10)

I haven't been able to find what causes or fixes this problem. But last Friday it did fix itself yet again and as always, i'm curious what fixed it... Could be anything from compiling the lighting to duplicating entities while the alt key is held down, etc..

Is there any file I could send you folks that might be able to diagnose what's going on? I wonder if I could send you an editor ini file or something next time it happens? Whatever you folks think might be responsible for breaking the alt-4,alt-5,etc hotkeys even after an editor close/restart.. The problem has to be saved into some file unless it's something that could be fixed by rebooting (which i haven't tried, because if i continue working for a couple of hours the hotkeys usually continue to work again by then for whatever random reason)

avatar image Steve Hardister ♦♦ STAFF Aug 08 '16 at 07:01 PM

Thanks for the update. Since I was not able to reproduce this locally, I thought it might have to do with your build but since this occurs often and on different machines for you, there may be a bug tied to a blueprint or other asset. So:

  • Can you reproduce this a blank project? If so, is it a blank Blueprint or C++ project?

  • If you have a project that you do not mind sharing where this tends to occur, you can send a link to the zipped project to me in a private message on our Forums.

avatar image KHM3dia Apr 15 '18 at 05:33 PM

It happens all the time for me, I switch between unlit and wireframe quite often when working with decals and it breaks. Have to manually switch them

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

btw i found how to fix the alt-numKeys in unreal. i have to go to photoshop and hit alt and then they'll start working again in unreal.

more ▼

answered Apr 16 '18 at 02:59 PM

avatar image

indigosm
46 3 7 14

avatar image GinoSL May 07 '18 at 09:53 PM

Wow that's weird, but it fixed it! I closed Photoshop and the issue isn't coming up anymore.

(comments are locked)
10|2000 characters needed characters left

Hi indigosm,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are still encountering an issue where the hotkeys for changing view modes are functioning sporadically, please provide the information and/or project as requested above and we will continue to investigate.

Thanks

Steve H.

more ▼

answered Aug 11 '16 at 07:52 PM

avatar image indigosm Aug 11 '16 at 07:58 PM

It's not resolved just so you know.. I've been closely watching to see when it happens again to try and find a way to make it reproducible... i'm hoping to find a way to reproduce it within another week or so but we'll see.. My current guess is that might be related to when I copy my unreal project to another machine, but haven't had a chance to test that yet.

avatar image Steve Hardister ♦♦ STAFF Aug 11 '16 at 08:34 PM

Thanks for the update. While this may not actually be "resolved" we mark it that way until an consistent repro can be provided (if we cannot repro the issue ourselves.)

So even though the answer is marked "accepted" the post will not be locked. This way, when you can repro the issue, even months from now, simply respond with these steps or project and we will pick it up from there.

avatar image indigosm Aug 25 '16 at 05:04 PM

so i've finally had the hotkeys break again. I opened the editor and it IMMEDIATELY reimported some texture files before the editor finished loading and I think that's what breaks the hotkeys. I was then trying to get the hotkeys to work again and I swore what seemed to fix them was to rebuild the lighting. So I tried that and it didn't fix them. I was thinking that maybe the reason why that didn't fix the lighting is because i didn't have to press the APPLY LIGHTING button that sometimes shows up after you compile lighting and it didn't appear this time. I'm not sure why that button shows up sometimes and sometimes it doesn't. My guess was that if you compile lighting and then don't do any changes to the level, it auto applies the lighting and skips loading that button? So I then pressed the compile lighting hotkey again and immediately started duplicating and moving some meshes, thinking the APPLY LIGHTING button would show up now because i have made some level edits while the lighting was being compiled. Well, the APPLY LIGHTING button still didn't show up so i'm still not sure why that button shows up, but what is fascinating is that it fixed the hotkeys.. (Btw, i'm duplicating the meshes by alt-dragging the tool handle, that might have something to do with it? just alt-duplicating meshes alone doesn't fix it because i've tried that. But maybe alt-duplicating meshes while lighting is compiling does. The only other logical fix is that you have to compile lighting twice? heh) So I then wanted to try and break the hotkeys again to get this to be a reproducible bug and so i closed the editor and overwrote 3 texture files. Then loaded the editor and noticed that it fully loaded the map and i was able to move around in it for a couple of seconds before it finally decided to auto-reimport the textures. After reimporting the textures, i found that it didn't break the hotkeys. ....continued in next comment...

avatar image indigosm Aug 25 '16 at 05:07 PM

So I THINK the only way to break the hotkeys is when you load the editor and it reimports changed assets BEFORE it finishes loading the editor. And I THINK the way you fix the broken hotkeys is to compile the lighting and then duplicate and move some geo around WHILE the lighting is compiling.. I'd love it if you could ask the coders if this would make any sense to them, because I can't find any way to get the editor to auto-reimport the textures before the editor is finished loading. I've tried like 6 times so far with various assets and it's always reloaded the assets far after the editor is finished loading and fully functional.

i'm guessing the auto-reimport system works on a global timer and it has to run across that timer while the editor is still loading and that's rare...?

anyways, i've been trying countless things to reproduce this bug and this is the only thing that did it. And i think it's also the only time i've just happened to reimport assets before the editor was finished loading so there might be something here....

avatar image Steve Hardister ♦♦ STAFF Aug 25 '16 at 08:03 PM

In regards to when you say that you "compile the lighting and then duplicate and move some geo around WHILE the lighting is compiling..." This is not good practice and hence would not be recommended to fix the hot key issue.

When you build lighting, it creates a physical texture where shadows are rendered for static items in the scene. So if you move a box while light is building there could be a shadow rendered for where the box used to be. In short, you only need to rebuild lighting when your done moving things around in a level.

As far as working on a fix for hot keys, there is so much work going on with the engine, anything that only occurs under very specific circumstances is not going to be given a high priority. That said, if you can establish consistent repro steps, on the other hand, it is very likely the bug will be addressed right away.

avatar image indigosm Sep 01 '16 at 05:49 PM

small update...

yesterday when i woke my machine from sleep (while unreal was open) the hotkeys stopped working and they refused to work the entire day. This morning I woke up the machine and the hotkeys started working again. Hrmm.. Still can't find a way to reproduce it but i am slowly ruling out various causes... :|

avatar image Spoondog Sep 27 '17 at 02:34 AM

I don't want to sound too useless because I don't have a repro case yet either, but I just wanted to say that indigosm isn't the only one experiencing this - I've had the viewmode hotkeys stop working too in 4.16 (unmodified launcher version). Fine after a reboot. Undo also stops working sometimes (which I now realize may just be that the hotkey for it stopped working as well - I'll test that next time I encounter it).

avatar image nickbruty Oct 12 '17 at 05:46 PM

This may be unrelated but I cant get hotkeys for the landscape tools to work consistently. It will work maybe one time when I initially go into the landscape tool but breaks straight away.

(comments are locked)
10|2000 characters needed characters left

@Indigosm Fix confirmed. Strange, but works. Thanks!!

more ▼

answered Apr 21 '18 at 09:45 AM

avatar image

RonnieNelis
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question