x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level Suddenly Takes Long Time To Save/Load

For no apparent reason my level suddenly takes FOREVER to load and save.

It has a landscape, couple of AI characters, some pawns and a few static mesh props. These were all there before this issue.

Anyone else had this problem?

Product Version: UE 4.12
Tags:
more ▼

asked Aug 06 '16 at 11:54 AM in Using UE4

avatar image

Michael Asquith
180 8 13 19

avatar image saeedc Aug 06 '16 at 10:59 PM

check the capacity of your drive c.

I had a problem like yours before but I am not sure if your problem is the same as mine

avatar image Michael Asquith Aug 07 '16 at 02:19 AM

Saeedc, thanks for the suggestion! C drive is not the issue, 170+gb free there plus I don't store my unreal projects on C - they are on a 4TB D drive (with 3.2TB free).

avatar image Michael Asquith Aug 09 '16 at 06:46 AM

Bumpety bump. Has anyone run into this issue?

Work on my game has come to a complete standstill. I cannot now save my level at all. It freezes at 45%.

I have a high spec system (i7 5960X), loads of RAM (32GB 3000) and lots of free disc space (3.2TB). My level was perfectly fine to save - and then it suddenly wasn't. Everything else saves fine.

I tried duplicating the level and systematically deleted objects to see if any one thing is the cause. The issue persisted.

I then, out of sheer frustration, deleted ALL the objects in the scene and still the level takes 10+ mins to save (Stuck on 45% for a long time).

Reopening the EMPTY level the issues persists (!?!?!?!). The emptied level is 126mb on disc. A new level saves very quicky and is 913KB on disc.

Why on earth does this happen?

How does a level get corrupted like this?

Can someone from Epic please respond?

avatar image Sean L ♦♦ STAFF Aug 09 '16 at 07:12 PM

Hey Michael,

A couple of things to try:

  • Migrate the map to a clean project and attempt to save it.

  • Create a new map in that same project and attempt to save that.

Let me know the results of both of those tests.

avatar image Michael Asquith Aug 09 '16 at 11:53 PM

Sean thanks for responding.

  1. Migrated map (and all dependencies) to a clean project. Map wouldn't load at all stuck on 75% - force quit after 15mins. Tried again, left for 30mins this time, same result.

  2. Created a new map. Threw in a landscape and a few game assets. Saved instantly. No problem at all.

I am only using two movable lights in the game - one directional (sun) and one skylight. I tried switching to fully dynamic lighting anyway in case it was a lightmap issue? Set Force No Precompute Lighting and rebuilt lighting. Set No Static Lighting in project settings. Restarted. No difference.

avatar image Sean L ♦♦ STAFF Aug 10 '16 at 01:59 PM

Thanks for performing those tests. It definitely appears that there is an issue with that particular map.

  • Could you please provide your dxdiag?

  • Could you please zip up the .umap file and provide it? You can PM it to me on the forums if you're concerned about privacy: https://forums.unrealengine.com/member.php?160394-Sean-Flint

  • Have you tried recreating the map from scratch to see if you experience the same results after a certain point?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day!

more ▼

answered Aug 15 '16 at 01:27 PM

avatar image

Sean L ♦♦ STAFF
43.9k 485 152 440

avatar image fancypride May 08 '17 at 07:52 PM

Hi there I am having the same problem as the person who reported this issue before. I am not sure if he managed to solve his issues, but I am unable to do so.

I am able to load all of our test maps quite easily but as soon as I try and load our main techdemo level, the level starts loading and then just hangs at 50%. Any ideas how I can solve this? I have scoured the net for an answer but haven't found anything that really helps me solve the problem.

avatar image Sean L ♦♦ STAFF May 08 '17 at 08:16 PM

Hey fancypride,

Unfortunately there's nothing I can think of that could cause this initially.

If the level contains a large number of assets, it's possible that the load times will just be extremely long. I'd recommend trying to delete the Saved and Intermediate folders from your project in order to see if that makes a difference.

Let me know if that makes a difference

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question