x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

day/night cycle with vxgi

I would like to know if it is possible to do a day/night cycle with the VXGI branch of UE 4.12 . I am able to get indirect lighting from my directional light but not the sky sphere. I thought VXGI supported unlit materials so it is unclear to me why a basic unlit material seems to emit indirect bounce from VXGI but not the sky sphere material (since it is also an unlit material type).

Product Version: UE 4.12
Tags:
more ▼

asked Aug 08 '16 at 01:56 PM in Rendering

avatar image

lromm
1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Possibly because the material the Skydome uses is not set to allow VXGI emittance. Find the material and open it up and take a look on the left side (can't remember the exact option name). Report back and let me know if the option is ticked or not. In the mean time I'll do some testing here.

EDIT: Yeah the option is unticked. "Used with Vxgi Voxelization" needs to be ticked in M_Sky_Panning_Clouds_2

more ▼

answered Aug 08 '16 at 02:11 PM

avatar image

GalaxyMan2015
290 3 4 24

avatar image GalaxyMan2015 Aug 08 '16 at 02:17 PM

Just doing some testing here, even tho the option is ticked, the SkyDome is just too far away. It will never be involved in the voxelization and therefore will not emit. Your best bet is to set the Environment Map option in the VXGI Diffuse/Specular section of the Post Processing volume to match the skydome and change it for day/night time.

Or use the skylight. Make sure VXGI indirect lighting is set to true on the Skylight

avatar image lromm Aug 08 '16 at 03:47 PM

Good to know and that is a shame that it's not compatible. Using the skylight is not ideal since i'd just end up doing the blueprint i'd be using without vxgi anyways. I was hoping vxgi could save me the time of having to set that up...I assume there is no way to bring the skydome closer? Couldn't I just rescale the sky sphere mesh?

avatar image GalaxyMan2015 Aug 08 '16 at 07:04 PM

Not really, I tried that, it has to be pretty close to be involved in the voxelization, the only two choices are Environment Map in the VXGI Post Processing options or a skylight.

avatar image lromm Aug 08 '16 at 07:21 PM

Bummer, well thanks for testing it out

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question