x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird self shadowing in 4.13 preview 1

Hi!

I've noticed weird shadow behavior in latest preview, I thought default bias for shadows was changed or calculation was modified. Here is a screenshot of default cube in default scene without any modifications to it in 4.12 and 4.13p1

Also, weird effect is getting stronger the further camera from the object.

Reproduce steps:

  1. Create a new default scene

  2. Drag and drop default cube in to the scene

alt text

Product Version: UE 4.13 Preview
Tags:
issue.png (404.0 kB)
more ▼

asked Aug 11 '16 at 09:53 AM in Bug Reports

avatar image

zeOrb
267 24 19 25

avatar image GalaxyMan2015 Aug 11 '16 at 09:59 AM

I'm not seeing the same thing. The shadow acne is about the same as 4.12.5 for me, and only appears when I am really close to the object (and very faint). The only way I can replicate the above pic is if I set the Shadow Bias to 0. So maybe check that the Shadow Bias is the same for both tests (Should be by default, as they are for me 0.5)

avatar image zeOrb Aug 11 '16 at 10:11 AM

I was able to get correct shadows by rotating around - under certain angles it's ok, but most of the time it's not

Everything is default, no changes to any settings

avatar image GalaxyMan2015 Aug 11 '16 at 10:15 AM

Odd yeah I see what u mean, it does occur to me too, but only when I originally place the cube 130 units or above along the X and below 40 units on the Z and only when the light is stationary, as soon as I switch to movable it goes away and if I switch back to stationary it still is gone.

avatar image zeOrb Aug 11 '16 at 10:20 AM

Oh, I found the problem I guess. New NVidia drivers fixed it :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

New NVidia drivers fixed the problem

more ▼

answered Aug 11 '16 at 10:20 AM

avatar image

zeOrb
267 24 19 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question