x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.12 Editor crashes on El Capitan 10.11.6

I was working fine with UE editor 4.12.5 under OS El Capitan, then I upgraded my El Capitan OS to 10.11.6, and now the editor (and the whole OS) crashes when I try to open my levels. The OS freezes and I have to reboot the computer.

It is not happening with a blank project. Only with my own levels.

Very bad surprise!

Product Version: UE 4.12
Tags:
more ▼

asked Aug 11 '16 at 11:48 AM in Bug Reports

avatar image

Panelsofsilence
86 4 6 12

avatar image Steve Hardister ♦♦ STAFF Aug 11 '16 at 06:39 PM

Hi Panelsofsilence,

It sounds like when you updated El Capitan, either some of your UE files became corrupt or this caused some mis-directors in your folders. I suggest following these troubleshooting steps:

  1. Make a back up of all your project folders from the Unreal Project folders

  2. In one of your original project folders in the Unreal Project folder delete the Saved, Intermediate and Config folders

  3. Launch the project from the project folder by right clicking on the uproject file instead of through the Launcher

  4. If the project opens, right click on the Contents folder in the Content Browser and select "Fix up redirectors in the folder" and save.

  5. If successful, save project and repeat these steps for the remaining projects

  6. Also, deleting the Config folder will require having to re-enter Project and Editor Settings. If successful, you can try replacing the Config file back to restore these settings (With the Launcher and Editor closed). If it crashes at this point, you'll have no other choice but to delete the Config folder and re-enter these values from scratch.

Steve H.

avatar image Panelsofsilence Aug 12 '16 at 06:46 AM

Hi Steve,

Thanks for your answer.

It's really weird : I formatted my hard drive and reinstalled El Capitan in the previous version, but it is still crashing. I tried your method with no success yet. Looks like all my projects went corrupted in 4.12. When I launch them, the editor becomes glitchy and makes the whole OS crash, (the OS doesn't respond anymore, and I have to reboot).

avatar image Panelsofsilence Aug 12 '16 at 06:51 AM

(I upgraded my project from 4.10 to 4.12, and when I come back to the previous 4.10 version, it's opening with no problems in UE 4.10)

avatar image Steve Hardister ♦♦ STAFF Aug 12 '16 at 01:48 PM

If your project opens in UE4.10 and is having issues in the UE4.12 version, I would:

  1. Make a backup of your 4.12versions and remove the original from your Unreal Projects folder

  2. (Either) Open UE4.12 and choose to open a copy of your 4.10 project

  3. (Or...) Create a new blank project in UE 4.12 then migrate the assets from your UE4.10 project.

*I'd suggest right clicking on the Contents folder and run "Fix up redirectors in folders" in the original UE4.10 project before trying these steps.

Lastly, please send the project file from the version of your project that is crashing:

(Hidden Folder) In Finder, Go>GoTo> ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

avatar image Panelsofsilence Aug 12 '16 at 05:20 PM

It's hard! I reformatted once again, installing only UE 4.12 and mac OS El Capitan : Copy from 4.10 to 4.12 didn't work Blank project didn't work Copy from Windows version (where it did a working 4.12) didn't work. I am running out of ideas. I join you the log files from the "blank project" version, and from the "windows 4.12 to mac os" version.

avatar image Steve Hardister ♦♦ STAFF Aug 12 '16 at 06:24 PM

Please send the system specs of your computer.

Your Mac's specs. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary)

The "System Report:" Apple menu >About This Mac > System Report>Hardware (All information listed in the "Hardware Overview.") You can cut and paste this information or provide screen shots, whichever is more convenient.

If the Crash Reporter window is present when the crash occurs, select "Copy Callstack to the Clipboard," and paste that information in a document and add to this post. Be sure to hit “Submit” on the Crash Reporter pop-up to send the Crash Report to Epic.

avatar image Panelsofsilence Aug 13 '16 at 07:14 AM

Hi Steve, here are my system specs :

Mac’s specs : iMac (Retina 5K, 27 pouces, fin 2015) 3,2 GHz Intel Core i5 8 Go 1867 MHz DDR3 Macintosh HD AMD Radeon R9 M380 2048 Mo

Hardware overview : Nom du modèle : iMac Identifiant du modèle : iMac17,1 Nom du processeur : Intel Core i5 Vitesse du processeur : 3,2 GHz Nombre de processeurs : 1 Nombre total de cœurs : 4 Cache de niveau 2 (par cœur) : 256 Ko Cache de niveau 3 : 6 Mo Mémoire : 8 Go Version de la ROM de démarrage : IM171.0105.B08 Version SMC (système) : 2.33f10

avatar image Panelsofsilence Aug 16 '16 at 09:05 AM

Unfortunately the issue not solve yet...

avatar image Panelsofsilence Aug 16 '16 at 12:27 PM

But I understood that having reformatted my HD, Mac OS is installing by default the last version of the OS, that means I am still in El Capitan 10.11.6.

avatar image Panelsofsilence Aug 13 '16 at 08:08 AM

I join you two crash reports : one of the UE Editor, and one of a builded game (it's a build I created just before my Editor issues. Now the build plays in the OS, but it's glitchy on the launch for a few seconds, and it crashes when I quit the game : maybe it is related to the main issue?)

avatar image ValentinaU Oct 17 '16 at 07:21 AM

Hello Panelsofsilence,

I have also started having problems with Unreal Engine 4.12.5 after updating to El Capitan 10.11.6 from Yosemite 10.10.5. May I ask you, how have you resolved your problem? May I also ask which operating system are you using now and whether it is working fine with Unreal Engine 4.12.5?

Thank you in advance for your answer!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi ValentinaU, I had to upgrade to Sierra, and that solved my issues. Good luck!

more ▼

answered Oct 22 '16 at 09:27 AM

avatar image

Panelsofsilence
86 4 6 12

avatar image ValentinaU Oct 24 '16 at 08:50 AM

Hello Panelsofsilence,

Thank you so much, it solved my problem too!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question