x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

MyCharacter and animBlueprint compiling

Every time I compile my MyCharacter I have to compile animBlueprint as well or my code won't work. Is this a bug? Inside the animBlueprint I call a few MyCharacter's variables. Is that the reason?

Product Version: Not Selected
Tags:
more ▼

asked May 22 '14 at 01:41 AM in Bug Reports

avatar image

Alex3d
63 9 15 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Alex3d,

Since your animBlueprint uses some of the variables in your MyCharacter Blueprint, then yes, you would have to recompile animBlueprint anytime you recompile MyCharacter.

more ▼

answered May 22 '14 at 07:36 PM

avatar image Alex3d May 22 '14 at 08:55 PM

This is a pain in the a**!!

avatar image Alex3d May 23 '14 at 04:31 PM

I don't really need to change anything. All I need is just switch between tabs (MyCharacter tab and animBlueprint tab ), and I will have to compile again. Even without editing anything.

For example: I compile MyCharacter Blueprint, then I compile animBlueprint, if I switch tabs, and go back to MyCharacter, even without touching anything, I will have to compile animBlueprint again, or the code will not work!!! And this is a bug!!!

avatar image Tim C ♦♦ STAFF May 23 '14 at 08:07 PM

Hi Alex3d,

I tried to do a simple reproduction of what you described, but I was unable to see that activity. Would you be able to provide a few more details? What version of the Editor are you using, and are you using an Editor compiled from Source or from the Launcher? Are you able to make this happen in a new project from one of the templates? Can you provide the steps that you are taking to set up your blueprints so I can attempt to follow the same process?

Thanks, Tim

avatar image Alex3d May 23 '14 at 08:49 PM

I will try with a new template and I'll get back to you.

avatar image Alex3d May 23 '14 at 09:11 PM

I tried with a new template, and I was not able to reproduce it also. So, it I thought that it is only with my project. Then I went to my project and tested it. I was able to reproduce. So, I decide to record a video, showing the problem, and I start to record it. Suddenly, I am not able to reproduce it anymore. And I didn't do anything to change the behaviour.

avatar image Tim C ♦♦ STAFF May 23 '14 at 09:38 PM

Hi Alex3d,

I'm glad to hear that the issue seems to have stopped. If you notice it again and can find a way to reproduce it in a new project, please let me know.

avatar image Alex3d May 23 '14 at 10:48 PM

Ok. Thanks for your attention.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question