x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Player spawn in the floor

Hi and Good Morning

I'm working on a 3D floor plant to a customer and have a deadline to deliver to Friday, 8/19/16, I rode a house in SketchUp, separated by parts and imported all the pieces and the Player Start is placed inside the house .

For some reason when I start the game, even clicking the right mouse button and using the ability to play on the screen, the player goes straight to the ground and gets its locked moviment. All collisions are set to Use complex collision as simple

If I start the game in any way out of the house, the Player functions normally.

PS: The house is positioned on top and has a terrain below the house. PS2: Some pictures showing the map with build light and some others not.

Sorry for my english =/ Thank you!!

https://answers.unrealengine.com/storage/temp/102558-01.png

https://answers.unrealengine.com/storage/temp/102559-02.png

https://answers.unrealengine.com/storage/temp/102560-captura%20de%20tela%20(8).png alt text

Product Version: UE 4.12
Tags:
01.png (1.3 MB)
02.png (1.1 MB)
more ▼

asked Aug 12 '16 at 05:43 AM in Bug Reports

avatar image

Estape
27 6 10 11

avatar image TJ V ♦♦ STAFF Aug 12 '16 at 03:40 PM

HI Drigo,

It sounds like the house may have had auto-generated collision on import and that is interfering; (the player could be starting inside of a large collision box.) Can you confirm that the house has no collision other than 'Use Complex as Simple'?

Does the player start sprite icon look normal or does it read, 'Bad Size'?

avatar image Estape Aug 12 '16 at 06:08 PM

Good afternoon There are two Block volumes that are on the balcony, so that the player does not see the left side of the scenery. And no, the height of the Player related to the ground is good, no bad Size.

avatar image TJ V ♦♦ STAFF Aug 12 '16 at 06:42 PM

As a test, try turning off 'Use Complex as Simple' and add in a floor collision for the character to walk on. Does it still have issues?

Just trying to narrow down if 'Use Complex as Simple' is what is causing the issue. If it is and the floor collision works, you could always just add more collisions to your other objects (walls, furniture, etc). It may not be ideal but it could help you meet your deadline.

avatar image Estape Aug 12 '16 at 06:58 PM

I removed all collision of the project, and in the process I realized that removing User Complex collision as simple on the part of the house, in sequence appears a auto generated collision, now when I start the Player above the house, 'he' dont teletranspot in the ground anymore, now the Player just going down as expect.

Now I will put step by step the collisions on the main objects and see if the Player will be go in the ground again.

avatar image Estape Aug 12 '16 at 07:49 PM

Ok, I just create a Block Volume on the floor and works fine, the Player don't go the ground anymore, but I got 2 more problems now. The rotation axis of the camera of the Player it's now ultra sensitive and when I move the mouse the camera move very very fast, and when I move to the balcony, I hit a collison, but there's no collision there.

alt text

alt text

01.png (972.6 kB)
02.png (108.0 kB)
avatar image TJ V ♦♦ STAFF Aug 15 '16 at 08:21 PM

Sorry for the delay. Are you still having this issue?

I'm not entire sure offhand what would be causing this. Would you be willing to send your project for me to troubleshoot internally? You could send me a download link via private message over the forums if you like.

avatar image Estape Aug 22 '16 at 07:06 AM

It is fixed now, thanks for the help!

avatar image Estape Aug 12 '16 at 08:14 PM

PS: My cable actor was going crazy shapes, so I delete them too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I fix, after remove all collisions, I transfer all content of the project and I put to the other. Thanks for support!

more ▼

answered Aug 15 '16 at 08:30 PM

avatar image

Estape
27 6 10 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question