x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Custom event is sometimes firing and sometimes not

I have a custom event that replicates to the server. I call it within a function if i get a hit from line trace. In the function I sticked breakpoints to the "call event" node. This node is always called when it should be called, but the event itself is sometimes firing and sometimes not. At the beginning it worked fine, this problem just occured a few days ago without me making any change to the project. I tried making the event new and restarting the project. Other custom events are working without any problems. It'd be great if I don't have to rebuild my game in a blank project because there is already quite a bit of content in the game, but I tried it with migrating the necessary assets in a blank project with the same result like in the main project.

alt text Here is where the event is getting called

alt text And this is where the event sometimes fires and sometimes not

This is my first question in a forum so I'm not sure if I provided enough information :/ If not just let me know.

Product Version: UE 4.11
Tags:
bugreport1.png (166.6 kB)
bugreport2.png (121.0 kB)
more ▼

asked Aug 12 '16 at 06:59 PM in Blueprint Scripting

avatar image

train0fpain
6 1 1 5

avatar image HaxO Aug 12 '16 at 08:14 PM

Is it only firing when ran from the server?

avatar image train0fpain Aug 12 '16 at 08:54 PM

When I put a print after the call-node and it prints it from the server it works for a few times, but after some hits it only prints from the client and thats when it is not working. I tried it with a "switch has authority", that calls the event less frequently even when it should, but at least the event fires everytime it is called.

What's also kind of strange is, that one specific hit animation seems to always bring the event to fire while the others act just as they please and sometimes work and sometimes not.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I changed the collision boxes in the character BP to "block all dynamics". It works fine now, but if somebody knows why "block visibility" wasn't sufficent when I'am using trace line by visibility, I'd be glad to hear an answer :)

more ▼

answered Aug 17 '16 at 02:17 PM

avatar image

train0fpain
6 1 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question