x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Is Screen Percent supported for HTC Vive?

I'd like to be able to improve the anti-aliasing quality of my VR projects by using a post processing Screen Percentage value greater than 100%. This works fine for Oculus Rift display, but when using a value greater than 100% and running on the Vive the left/right eye projections go way out of alignment and are unusable. The effect is somewhat similar to crossing your eyes.

Is the Vive supposed to gracefully support Screen Percent values other than 100%? Have I found a bug?

Steps to reproduce:

  1. Create a new project using the "Blank" template.

  2. Add a Post Processing volume.

  3. Tick the "Unbound" property of the volume to "true".

  4. Under "Post Processing > Settings > Misc >" turn on "Screen Percent" and set it to 120.

  5. Preview the project in VR.

  6. Notice the misalignment.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 12 '16 at 07:05 PM in Rendering

avatar image

Krxtopher
820 27 15 56

avatar image Minos Aug 27 '16 at 07:18 AM

I have the exact same problem. In the past, I have been able to set screen porcentage with a DK2 very easily, but now with a Vive and Unreal 4.12 I simply can't anymore. I tried setting console commands via blueprints, post process volumes (running into the same problem you did) and even fiddling with .ini files, with no success. The funny thing is that I'm able to increase the screen percentage in the editor but not in the packaged game.

It's quite possible that I'm overlooking some tiny step along the way (there are thousands of different places you can set screen percentage in the engine lol), but frankly, I just have no energy to look into this anymore.

Hopefully someone finds a solution soon or Epic fixes it if it turns out to be a bug.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I have the same problem... Any solution yet?

more ▼

answered Nov 07 '16 at 10:54 PM

avatar image

fabito rychter
16 2

avatar image rczarnowski Nov 11 '16 at 04:46 PM

HTC Vive handles screen percentage in a different way. Have a look here, under Common Commands: https://docs.unrealengine.com/latest/INT/Platforms/VR/CheatSheet/

(comments are locked)
10|2000 characters needed characters left

a have the same problem and find way to fix it, just use console comand r.ScreenPercentage 200 to set it on 200

more ▼

answered Jan 11 '18 at 07:20 AM

avatar image

weratq
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question