x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor asking me to save files that don't need to be saved?

Every time I "save all modified assets" in the content browser I see the same 3 files show up, even if I already saved them. They will stay saved unless I run the game. Every time I run the game, I have to save these files again even if I made no changes to them.

Edit: If I play a standalone game, then I don't need to re-save, but playing in a new editor window or the current editor window, I see the asterisk on my asset as soon as I launch it.

Product Version: Not Selected
Tags:
more ▼

asked May 22 '14 at 09:51 AM in Bug Reports

avatar image

Kochab
514 59 164 122

avatar image Ben Halliday STAFF May 22 '14 at 05:15 PM

Hey Kochab,

Would you mind linking me to one of your .uassets that are causing this to occur? And just to be sure I understand, this happens when you try to Play in Editor? Thanks!

avatar image Kochab May 22 '14 at 05:45 PM

Here is a link to one of my problem uassets: http://www.mediafire.com/download/55bnm2h9mg2k17u/SHud.uasset

Yeah, it happens when I Play in Editor.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

more ▼

answered Oct 03 '14 at 06:34 PM

(comments are locked)
10|2000 characters needed characters left

Hey Kochab,

I see you're doing some casting in this Blueprint, so I think I see the cause of the problem. When you save a BP that casts to another BP, that second BP becomes "dirty." A dirty BP asset isn't counted as a modified asset, so when you Save All Modified Assets those dirty assets won't be included.

I'm guessing you cast to this HUD BP from another BP, and the same is true for all 3 assets this occurs with. If that's the case, try using File > Save All and see if that solves the problem. Let me know if it still happens after trying that.

Best,

Ben Halliday

more ▼

answered May 22 '14 at 10:26 PM

avatar image Kochab May 23 '14 at 12:01 AM

Oh, I see. Thanks for the answer. I'll let you know as soon as I get a chance to test it.

avatar image Kochab May 23 '14 at 01:19 PM

Didn't work. They still need to be saved after File > Save All and running the game in the editor.

avatar image Ben Halliday STAFF May 23 '14 at 11:01 PM

Are each of the three files cast to from another Blueprint? Are there any shared variables between the files in question and other BPs? Just want to make sure I'm looking in the right direction. Thanks!

avatar image Kochab May 23 '14 at 11:40 PM

Yeah, all the problem files cast to other blueprint files. The 3 files that have to always be saved are: player, scout, and hud.
Player BP has casts to: scout, two weapons, gamemode

Scout BP has casts to: player, generic pawn, an actor placed in the level

Hud BP has casts to: player

No shared variables and no interfaces. As far as variables I just cast to the BP to gain access to the variables I need in other BPs.

avatar image Ben Halliday STAFF May 23 '14 at 11:57 PM

And do any other Blueprints cast to those 3?

avatar image Kochab May 24 '14 at 12:53 AM

I only found one other blueprint that casts to player.

avatar image Ben Halliday STAFF May 25 '14 at 05:15 PM

Hey Kochab,

I'm sorry, but I have not been able to reproduce the issue on my end. Save All really should work, and I can't think of anything that would modify or dirty an asset during PIE. Even using the .uasset you sent, I wasn't seeing the same issue.

I'm afraid without being able to reproduce the issue I don't think I can help. I will keep trying, and will let you know if I see what's causing the issue.

Best,

Ben Halliday

avatar image Kochab May 25 '14 at 07:17 PM

It's really just a minor annoyance. It was confusing at first cause I wasn't sure if I made any changes to the files. I was just hoping it was an easy fix. I thought it might be that my scout was casting to a placed level actor, but I took those nodes out and it's still doing it. Who knows.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question