x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Blueprinteditor slowing down massively?

Hey!

I have a massively slowing down Blueprint-Editor after a short periode and short amount of nodes I created until I nee a few seconds until something happen in the BPE. I have the issue with 4.12 and 4.13. I cant find something about (but maybe I ask google wrong) it. Just read something about a memory leak. But it start to slow down long time before my memory is really "used".

My spec: I7 4770k 12gb RAM R9 290

I had never problems like that. Thanks for all informations.

greetings Alex

Product Version: UE 4.13
Tags:
more ▼

asked Aug 14 '16 at 05:34 PM in Bug Reports

avatar image

Beeti
1 1 2

avatar image Adam Davis STAFF Sep 06 '16 at 03:52 PM

Hi everyone,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • What steps can I take to reproduce this on my end?

  • Can you post your full dxdiag here so I can take a look?

  • Have you updated to the most recent drivers for your R9 290?

  • Have you checked to see if the memory was steadily increasing in the task manager while in use?

  • Does the editor eventually crash if left alone?

  • Do you see any error messages or warning?

  • Does this seem to occur with a specific node/node combination or is it when you use any blueprint nodes?

avatar image Beeti Sep 06 '16 at 04:22 PM

Hey Adam!

Does this occur in a clean, blank project with no additional content or is it limited to one project?

Yes, it occurs in all projects.


What steps can I take to reproduce this on my end?

This is a good question. I just create a blank project, create a blueprint and start to add nodes. It is nothing I do more than that to reproduce that.


Can you post your full dxdiag here so I can take a look?

Sure, here you go.link text


Have you updated to the most recent drivers for your R9 290?

Yes. I always do ;)


Have you checked to see if the memory was steadily increasing in the task manager while in use?

Yes I checked and tried, if somewhere something else stack the memory, but no nothing else do it like that. It is only if I click the right mouse button and add a node. (I am sure I dont try ALL, but all I saw in the first place)


Does the editor eventually crash if left alone?

No, it never crashed. The editor just want to set the settings down, because I got less than 10 fps for more than 80% in 30 seconds.


Do you see any error messages or warning?

No, I cant see any error or warnings.


Does this seem to occur with a specific node/node combination or is it when you use any blueprint nodes?

Any blueprint nodes.

dxdiag.txt (107.4 kB)
avatar image Adam Davis STAFF Sep 07 '16 at 07:40 PM

Unfortunately I'm not seeing this error occur while adding blueprint nodes. Do you have any additional steps I can take or a video showing what you are experiencing?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi Beeti,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Sep 12 '16 at 02:12 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

have same problem :<

more ▼

answered Aug 18 '16 at 06:32 PM

avatar image

Dekoy
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

New update and still the same Problem :( I dont know what to do. I cant restart the engine after 5 minutes all the time. I think I just forget something, do I?

more ▼

answered Sep 03 '16 at 12:01 PM

avatar image

Beeti
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

alt text

Maybe this will help to show a bit of my problem. As you see it drops down to 1.8 fps and and 558 ms. It is hard to work with :D

udk.png (977.8 kB)
more ▼

answered Sep 04 '16 at 08:41 AM

avatar image

Beeti
1 1 2

avatar image Dekoy Sep 05 '16 at 06:32 PM

My editor after leaving it on for 30 minutes without touching consumes nearly 15 gb, and the project contains almost only scripts. So yep, heavy memory leaks.

avatar image Beeti Sep 06 '16 at 11:19 AM

Oh Wow. That is awesome, too :D I really want to work with, but this is too hard atm. D:

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question