Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio Community Errors Prevent C++ Programming

Okay so I have been having trouble with pretty much every step of installing and using Visual Studio for Unreal since the very beginning. I understand that a lot can be done with the Unreal Visual Scripting however, my aim is to script using C++ simply because of the versatility and my past experience with other scripting programs such as C# for Unity and Python for Blender3D.

Unreal, or rather Microsoft VS has presented a problem for me and I hope someone can help me out here. First of all, when I try to install Microsoft VS Community, the installation always gets stuck at ASP.net. I leave it for hours and overnight but no progress is made. After research, people found solutions by tricking the computer into thinking it was shutting down to force the installation to the next step. That worked, and it got stuck somewhere else along the way. When it finally did finish, I was given these errors alt text

I went to my control panel to see everything that was installed ad could not find these files. Maybe I was looking in the wrong place, but I went to repair the installation and this came up: alt text

Same error messages. So despite that, and after multiple failed attempts of uninstalling and reinstalling, I decided "What the heck, let me go ahead and try to open it in Unreal." Obviously that wasnt going to work but I did it anyway.

When trying to create a C++ project, when it comes time to compile before opening the project, This comes up: link text

Also tried it on an example project and this text came up: link text

I can't find any working solution to this problem so I have come to the community for help. Hoping this can eventually be resolved and thanks in advance!

Product Version: UE 4.11
more ▼

asked Aug 15 '16 at 02:25 PM in C++ Programming

avatar image

The Big One
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

My only guess is that while the installer can write to your registry it is having permission errors that prevent it from writing to your program folders. Are you running the installer as administrator and are you installing at the default location?

more ▼

answered Aug 15 '16 at 03:54 PM

avatar image

1.2k 31 8 40

avatar image The Big One Aug 15 '16 at 05:06 PM

The very first time I do not believe I ran it as admin but since then I have ran the exe as administrator and got the same results. I am wondering if it never fully uninstalled, I did so from the control panel so it should have gotten rid of all files linked with visual studio but not sure. And yes, I have always left it to install in the default location

avatar image Shohei Aug 15 '16 at 05:28 PM

My next step would be to manually install the redistributables.


You can also follow the instructions in this answer.


avatar image The Big One Aug 15 '16 at 05:35 PM

I will give this a shot, thanks. When I'm done I'll come back and report what happened.

avatar image The Big One Sep 19 '16 at 11:19 PM

Hey thanks for the help, I wound up having to send my computer in for repairs because there were a lot of internal problems with it. It recently came back and Visual Studio installed fine without a problem and I was just able to check out some coding in Unreal.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question