x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

What is up with these load times?

Ok back in the day the tools were fast and pretty stable for the most part. You use to be able to place a new object and it would throw the world material on it until the shaders were compiling. When you right clicked on a map to delete it you could just do that -sort of-.

Now when I click on anything it takes a upwards of 1 to 5 minutes to load and freezes up the editor. Sometimes I am so frustrate this is getting in the way of creativity I just quit for the day. I know once those materials are shaded and built it won't do it again but man this is really getting in the way of my level design.

Is there a way to set it back to the old way because this is making me want to cry. I spend alot of time flipping off the editor because it stands right smack in the way of my creativity.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 15 '16 at 06:27 PM in Using UE4

avatar image

Drixil
134 6 11 17

avatar image Matthew J ♦♦ STAFF Aug 16 '16 at 04:01 PM

Hello Drixil,

Are these freezes something that only happen in your project or does it happen even when working a blank project? Does it continue to happen in a fresh map inside of your project? After one of the freezes, try checking the output log to see if any errors are being output there. It could be the same symptom of another user I saw recently where there was an infinite loop in one of his blueprints, resulting in freezes whenever he did most actions.

avatar image Drixil Aug 16 '16 at 04:51 PM

Nope it is in blank projects, full projects, new projects I thought it might be the engine itself so I reinstalled. This had happened with 4.9 and reinstall fixed it. But not in this case. Sometimes it will place the objects with a world grid material it did this once yesterday and made me wait on several other assets on that new project. I will check the output log today and see what it says. But the placing of a newly imported objects really isn't going to say much.

avatar image Matthew J ♦♦ STAFF Aug 18 '16 at 07:57 PM

Ah, so is this only with freshly imported objects? Are these objects complex? Would it be possible for you to share the FBX for one so that I can see if I can get the same kind of result?

avatar image Drixil Aug 18 '16 at 08:24 PM

Sadly No they are market assets. But most of them are very simple for the most part. For example I place a wall from the abandoned places asset. It doesn't have any materials on it. Then I place a material and it takes forever. This happens with any material asset I just import. If the FBX file has a asset on it it takes double the time. Once I have loaded it the first time it is fine. But here is the rub. Lets say I want to delete a overview map. I right click on it or just click on it and I am waiting 5 minutes for everything to load before I can delete it. It is lame... I want to turn that off....

avatar image Matthew J ♦♦ STAFF Aug 18 '16 at 08:34 PM

Just to be sure, are these long load times only happening when the shaders are being compiled and it doesn't happen otherwise? If that's the case, there isn't really anything we can do. Shaders must be compiled in any situation and should only need to be done once.

avatar image Drixil Aug 18 '16 at 08:44 PM

Ya but why can't I place the damn object and then the shaders compile like in the old days of 4.1 through 4.9? I mean it is really dumb to compile the shaders if someone selects something and then has to wait for 1 to 5 minutes before the damn editor becomes available again to do anything. I mean that is not good programming it gets in the way of the artistic process majorly...

avatar image Matthew J ♦♦ STAFF Aug 18 '16 at 08:52 PM

There's no reason a simple asset should be freezing your editor for 1 to 5 minutes, and we've had no reports of this happening in 4.10 or any other recent versions which leads me to believe it isn't a version issue. Is any of this project connected to a network drive or source control? Would it be possible that your computer is trying to access the DDC over a network instead of locally? Have you tried setting up a local DDC? Could you provide a DXDiag so I can get an overall idea for the specs of your computer?

avatar image Blue man Sep 06 '16 at 08:12 PM

Hi, I also noticed this but only with the Marketplace assets, this doesn't happen with my assets. It only happens the first time I select that asset. I am not an expert but it seems like the Engine gets confused when you import the assets from the Marketplace, it seems like it is generating something for that asset.

avatar image Drixil Aug 18 '16 at 09:04 PM

NOPE no source controll I have never been able to actually get it to connect so I have to do it manually. But I am telling you I did not have this problem before 4.10 and I just reinstalled a few days ago thinking that might be the issue. This had happened once before with screen shots and all kinds of personal computer information and reinstall was the only thing to fix it. Though in that case many things were lagging memory wise and it cleared out on reinstall... This time the only thing I accomplished was breaking my card game so it can't recompile... That is another story that is for another day...

This reinstall didn't do anything. Didn't fix anything... The only software having any issue is the editor... I have defragged my drive clear all my temp directories well I do that everyday as well as my registry. I do daily maintainence on my machine. And as far as the DDC goes I leave it default because of situations in the past where I had a small system drive. I bought another one just so I didn't have to suffer the DDC issues of moving it in the engine INI....

avatar image Matthew J ♦♦ STAFF Aug 23 '16 at 01:25 PM

To ensure that it isn't something else that has changed, have you tried installing 4.9 and seeing if you get the same load times there? If you're not willing to try creating a local DDC or providing any of the FBXs that you're having this problem with (I understand if they're marketplace content, but even mentioning which pieces of content they are would help) then there isn't really much I can do.

avatar image Drixil Aug 23 '16 at 03:56 PM

Oh boy I just looked at my previous post when I had to reinstall and this issue actually started at 4.5 and has just gotten gradually worse, I am fairly certain I know what it is. It is probably the DDC. This is what I am thinking is happening anyway. It takes along time to import new stuff, much longer than it use to. I always thought it was referencing everything and that what was taking so long.

For example: a character Model use to take about 30 to 40 seconds. Now days it takes anywhere from 30 seconds to 5 minutes depending on the size and the complexity. However maybe it is not Caching the materials/textures. So when I load the asset the first time it has to do that which sometimes is staggering how a 512X512 texture can take so long to cache.

I suppose in 4.1 to 4.4 I got use to placing a freshly imported object and that object having a world grid material temporary placed on it while it cached. Now the editor freezes while the object gets sorted into the content browser and referenced.

There is also the option that it is just taking a long time to load the mats. Yesterday I placed a box with middle of the line resolution textures and it took about 5 minutes of the editor being frozen. The editor was using all of my CPU and about 5gigs of my memory. It kept becoming unresponsive because during that process it started building shaders right in the middle of the import.

The shaders are a big issue and always have been because they just start building adding processing power whenever. But they only seem to melt down the editor when I am building lighting and they go off or when I am importing something.

avatar image Matthew J ♦♦ STAFF Aug 26 '16 at 06:41 PM

This doesn't seem all that outrageous if you're not using a DDC, depending on your computer's hardware. Complexity will definitely make a difference in how long it takes to import, especially if you're including morph targets as they require a lot of calculation.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

We haven't heard from you in a while, Drixil. Are you still experiencing this issue? If so, was my last comment of any help? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Sep 06 '16 at 07:59 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 92 417

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question