x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] [4.13 p2] MediaTexture black on videos in Android 4.1.2

It worked everything ok in preview 1. But now, in preview 2, videos on Android 4.1.2 play, you can hear the audio, pause etc, but the MediaTexture keeps black. On 4.4 it's still working, with visible video.

Tested both in my project as in a blank one. Using a material with a MediaTexture as a brush on Image widget, in UMG.

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 17 '16 at 12:05 AM in Bug Reports

avatar image

RVillani
1.1k 27 37 89

avatar image AndrewHurley Aug 17 '16 at 02:13 PM

Hey RVillani,

Can you provide me with some screenshots of your set up and some steps to follow, as well as the device and its specifications so I can test this issue on my end?

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

avatar image RVillani Aug 17 '16 at 03:13 PM

Of course, Andrew.

The Android devices where the video is blank:

  • Samsung Galaxy 10.1 (GT-N8020) with Android version 4.1.2. Compilation number JZO54K.N8020UBAMD1.

  • Nexus 5 with Android version 6.0.1, version number MOB30Y.

    A device where the video is visible:

  • Samsung Galaxy Note 2014 with Android 4.4.2. Build number KOT49H.P605XXUCNE2.

    Steps to reproduce:

  • Create a FileMediaSource from a mp4 video placed in the Content/Movies folder.

  • Create a MediaPlayer from it.

  • Create MediaTexture and MediaSoundWave from the MediaPlayer.

  • Create a material with domain set to User Interface and use the MediaTexture as emissive.

  • Create a UMG, insert an Image in the canvas and set the material as it's brush.

  • On the UMG graph, create two variables: MediaPlayer and MediaSoundWave. Set the previously created assets as its default values. On begin play use the MediaPlayer's Open Source node to open the FileMediaSource asset and use the MediaSoundWave's Play Sound 2D node to play the sound. The WorldContextObject can be Self, Player Controller or whatever. The result is the same.

  • On an empty level, on BeginPlay event, create a widget from the UMG class and add it to viewport.

  • Test it. On PC it runs fine. On Android the audio plays fine, but the texture keeps it's Clear Color.

    Images from my assets setup

    FileMediaSource MediaPlayer and MediaSoundWave MediaTexture Material UMG Design

avatar image RVillani Aug 17 '16 at 03:21 PM

Assets continued

UMG Graph Level Blueprint

Also, these are the GSpot prints using the two videos I tested with GSpot

Out of curiosity, I also tested setting the Clear Color of the MediaTexture to red. And the screen was red on the problematic devices. So the Material is rendering. And we have audio, so the video is playing. It's just the texture that is not updating.

Here are my Android and Android SDK settings: alt text

The problem presents itself no matter the build configuration (Shipping, Development etc) nor the texture compression settings (ETC1, ATC, Multi).

Thank you for your time, Andrew! Hope you guys can figure this out.

umg_graph.png (191.8 kB)
levelbp.png (188.3 kB)
gspot.png (101.0 kB)
android.png (98.7 kB)
(comments are locked)
10|2000 characters needed characters left

The question has been closed Aug 30 '16 at 08:51 PM by RVillani for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hey RVillani,

Thanks for the clear and precise repro steps. I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the issue following the link below on our new Public Issues Tracker.

UE-34898

Once the issue has been addressed by our engineers, the fix will be added to the release notes for fixed issues within an upcoming full engine or hotfix release.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

more ▼

answered Aug 18 '16 at 05:16 PM

avatar image RVillani Aug 18 '16 at 05:30 PM

Thanks, Andrew! Also, just mentioning again because that's where I'd start from: on preview 1 it worked. So, maybe, looking at the changes from 1 to 2 may help a lot. I'd try and help more, but after a year using the engine, I still haven't had the time to study the source thoroughly.

avatar image Chris Babcock STAFF Aug 24 '16 at 06:25 PM

UE-34898 has been fixed. Here is the GitHub commit for 4.13: link text

avatar image RVillani Aug 24 '16 at 09:48 PM

Thanks a lot, Chris! I've tested it in my project and it is working flawlessly! =)

avatar image ERuts Jul 18 '18 at 02:21 PM

I have the same problem in UE4.19.2. Do you know how to fix it? I have a h264 mp4 video and checked the paths. On Android black screen with audio. On PC video and audio.

avatar image rasamaya Nov 23 '18 at 01:37 AM

same as ERuts, did you solve this?

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question