Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to package project after adding New C++ Code


I have been crawling the forums and so on to try to find an answer for this issue. Even if it's a new project or adding to an old one. I still get the same issue. And it is no different if I use a different version. I even reinstalled windows with fresh engine installs and same thing happens.

New or working project -> New C++ Code... (And I know the code works as it compiles and runs in the editor without any issues.) -> Package project for Windows 64bit... -> And then the build failed comes up.

Product Version: UE 4.13 Preview
more ▼

asked Aug 17 '16 at 07:32 PM in Packaging & Deployment

avatar image

5 6 8 10

avatar image Sean L ♦♦ STAFF Aug 17 '16 at 07:34 PM


Could you please attempt to package again and when it fails, provide the full output log from your project's Saved->Logs folder?

Thank you

avatar image AinSophAur Aug 17 '16 at 07:39 PM

Sorry. I forgot to add it. I had it ready before I postet. My bad.link text

outputlog.txt (6.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After taking a look at your log file, I'm seeing this error:

ERROR: AutomationTool terminated with exception: System.ArgumentException: An item with the same key has already been added.

Here are a few resolved posts where users experience the same issue. Take a look at them and let me know if the solutions resolve your issue.




Have a great day!

more ▼

answered Aug 17 '16 at 07:44 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image AinSophAur Aug 17 '16 at 08:15 PM

This is unbelievable. After finally being able to understand what Samantha said the first link you gave me there. It worked like a charm.

Thank you very much for your help and time Sean. You have a great day as well. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question