x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 - Splinemesh ignores Phys Material Override

As stated, create a splinemesh, give it a Phys Material Override, and the splinemesh ignores it completely.

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 18 '16 at 04:46 PM in Bug Reports

avatar image

Juice-Tin
152 38 37 45

avatar image TJ V ♦♦ STAFF Aug 19 '16 at 06:03 PM

Hi Juice-Tin,

I attempted to reproduce this behavior but the physical material is registering for me. Here is what I did.

  • Created a line trace from the character that prints any physical material it finds

  • Set PhysicalMaterial Override on the Splinemesh on EventBeginPlay

  • On hit, the correct physical material that was set is found

If you are seeing something different or if I tested this incorrectly, please include repro steps and screenshots for me to follow.

avatar image Juice-Tin Aug 20 '16 at 07:10 PM

Hi TJ,

I created a test project and did the same, except the Phys material is added through the details panel's collision category. Both splinemesh and static mesh ignore it completely this way, and it only works when added through a material.

I've added the test project so you can check out for yourself. Inside the rar are some extra notes. http://www.sky9games.com/StaticMeshTest.rar

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

After further investigation, this is working as intended. The reason you are seeing the Default Physical Material being returned is because you are using Trace Complex on your line trace, which only looks for complex collision. If you look at the tooltip for Physical Material Override, you'll notice that it uses the override only for simple collision. If you disable Trace Complex on your line trace node, you'll get the desired return, which in your case is the Test physical material.

Hope that helps

more ▼

answered Aug 26 '16 at 05:43 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image Juice-Tin Aug 27 '16 at 01:03 AM

Ahhhh. I recently noticed it was for simple collision only, but I never would have thought it also affected simple/complex traces. Thanks for the explanation!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question