x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why am I getting the "UE4Editor-MyGame.dll is missing from your computer" error on my new computer?

Why am I getting the "UE4Editor-MyGame.dll is missing from your computer" error on my new computer?

I never had any issues building and launching the game; however, I recently got a new development computer. Now, whenever I get latest, build, and run the game, I get the following error:

The program can't start because UE4Editor-MyGame.dll is missing from your computer. Try reinstalling the program to fix this problem.

None of my coworkers are experiencing this error, and I had never encountered this error on my old computer. All my development paths are the same between the new and old machine. I am able to successfully launch the game by making the following changes to FModuleDescriptor::LoadModulesForPhase():

 void FModuleDescriptor::LoadModulesForPhase(ELoadingPhase::Type LoadingPhase, const TArray<FModuleDescriptor>& Modules, TMap<FName,     EModuleLoadResult>& ModuleLoadErrors)
 {
   FScopedSlowTask SlowTask(Modules.Num());
 
 #pragma region DLL Path Hack
 
   // #HACK: Force the module manager to search the game folder for .dlls.
   // This directory should already be searched, but Unreal can't find any .dlls in
   // this directory without explicitly adding it here.
   FModuleManager::Get().AddBinariesDirectory(TEXT("E:\\UE4\\MyGame_Dev\\MyGame\\Binaries\\Win64"), true);
 
 #pragma endregion DLL Path Hack
     
   for(int Idx = 0; Idx < Modules.Num(); Idx++)
   {
     ...

What could be causing this issue? Could it be a missing path variable or registry value? It doesn't prevent development, but it is disconcerting that, while my coworkers can run the game straight from the depot, I have to modify engine files to run successfully. Any help would be greatly appreciated!

Edit

I did notice this little gem a few lines down:

 // @todo plugin: DLL search problems.  Plugins that statically depend on other modules within this plugin may not be found?  Need to test this.
 
 // NOTE: Loading this module may cause other modules to become loaded, both in the engine or game, or other modules 
 //       that are part of this project or plugin.  That's totally fine.

Not sure if the "DLL search problems" could be a computer-specific thing, or if it was ever tested. In any case, if it wasn't tested, it would appear that they need to be tested. :)

It looks like that was added by Ben Marsh for CL 2119335 in commit 8d04b79. Not sure if this info helps, but it's where this function was originally implemented and where it's failing.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 18 '16 at 06:06 PM in Installation & Setup

avatar image

ZacharyLewis
44 2 5 8

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 06:15 PM

Have you rebuilt the engine since being on your new computer?

avatar image ZacharyLewis Aug 18 '16 at 06:17 PM

Yes. I've done full rebuilds, and I've even deleted all local files and got a clean copy of the codebase.

One concern I have is the fact that we are checking in the binaries for artists. I'm not sure if that could cause any issues on only my computer, however.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 06:22 PM

Are you on Mac or Windows?

avatar image ZacharyLewis Aug 18 '16 at 06:27 PM

I'm running Windows 7. I'm using Visual Studio 2015 for development and Perforce for source control.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 06:43 PM

Is the "MyGame" bit before .dll the name of your game project or of a plugin you have installed for your project?

avatar image ZacharyLewis Aug 22 '16 at 05:59 PM

It's the name of my game project.

avatar image BobWhite Aug 18 '16 at 06:27 PM

We've had this issue pop up on quite a few artist machines. Currently doing some horrible hacks like copying our game DLLs into the engine\binaries\win64 folder, because the solution of hard coding in the game binaries location fails miserably when everyone has their workspace mapped to some random drive. Windows only so far.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 06:38 PM

I would recommend not sharing the binaries between computers. While I can't say for sure that is the issue, it certainly sounds like it could be.

The documentation says that the following folders "should" be added to your SVN / Perforce:

  • Config

  • Content

  • Source

  • ProjectName.uproject

  • ProjectName_Preview.png (if it exists)

As for Binaries, it says its "optional", which suggest that maybe its not the cause of your issue but the documentation is also a bit out of date.

I will keep looking around and see if I can come up with a more concrete solution.

avatar image ZacharyLewis Aug 18 '16 at 06:44 PM

Thanks, Kyle. As a follow-up, if binaries aren't submitted, how would you recommend people who don't build locally (artists, level designers, et cetera) stay up-to-date with developers?

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 06:55 PM

They would need to download Visual Studio, get either the Release branch you are on via Epics GitHub / get your groups version of the engine, and build the engine.

Now, that is a judgement call on your end, which I think is why the SVN / Perforce documentation says that including the binaries is "optional".

For your issue, I would try this, just as a sanity check.

Get the 4.12 branch from Epics GitHub and run through the steps:

  • Run Setup.bat and wait for the dependancies to download.

  • Run GenerateProjectFiles.bat

  • Open UE4.sln

  • Compile 4.12 (Development Editor)

  • Run via Visual Studio

  • Create a new C++ Project.

  • Run the project via Visual Studio

See if that functions.

avatar image Shohei Aug 18 '16 at 07:26 PM

This doesn't sound right considering all binaries should be using relative paths.

The missing dll is the core game dll. It is the result of compiling your main game project. Theoretically I can confirm this since moving my entire project directory to another directory allows me to open the game with the editor. What is more concerning is that it says "Try reinstalling the program to fix this problem.". Normally if the dll is missing UBT would ask you if you want to rebuild them.

alt text

If this message is not appearing my only guess is that it does not provide this option on computers that don't have Visual Studio installed. That doesn't resolve the issue that the dll exists in the first place, though. With regards to that we may need to see how the dll is being referenced in the .build.cs file as well as the modules listed in the .uproject file.

capture.png (6.3 kB)
avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 07:32 PM

Also, can you navigate to:

 UnrealProjectsDirectory/GameProject/Binaries/Win64 

See if your "UE4Editor-MyGame.dll" file is there. (My assumption is that it wont be)

avatar image ZacharyLewis Aug 22 '16 at 06:01 PM

It's 100% there. That's why the hack mentioned in the original question works.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 07:56 PM

Can you also let me know if you have the source code for your engine or if you are a artist on the team relying on the binaries?

avatar image BobWhite Aug 18 '16 at 08:59 PM

I have source, and a compiler. Our artists are syncing the same repo, so while they have source, they don't have a compiler to rebuild with. All of the binaries are there, and I've deleted and resynced their workspaces multiple times while working through solutions. The problem does seem to solve itself when I copy the binaries from /Binaries/Win64 into Engine/Binaries/Win64. So everything is building properly, it just seems to fail oddly when trying to load.

I've even tried explicitly adding our game/binaries/win64 to the PATH environment variable, but that did not help. Seems the engine ignores PATH when trying to track down plugins and modules.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 09:04 PM

When you launch the project, do you always launch through the launcher or through the .uproject?

Or, do you launch the game project through Visual Studio?

I ask because I have been seeing what happens when i start moving things around and deleting files. Whenever I launch the game project through Visual Studio, it rebuilds what I've moved or deleted and loads the project fine. Whereas, if I do the same and try to launch through the .uproject, it gives me a flat error with no ability to remedy it.

avatar image BobWhite Aug 18 '16 at 09:18 PM

I always use the uproject, I've actually never installed the launcher on my primary dev machine. Our art team is split, some have installed the launcher, some haven't. For art folks hitting this bug, I know at least 2 of them didn't have the launcher installed, and at least 1 does.

avatar image ImVawx ♦♦ STAFF Aug 18 '16 at 09:24 PM

Can you try on a machine that is experiencing this issue that also happens to have the source code and Visual Studio, launching the game project .sln file and then pressing the "Local Windows Debugger" button.

Might take a few minutes for Visual Studio to "warm up" but let me know if the editor will launch and if you still get the same issue launching through Visual Studio.

Thanks.

avatar image BobWhite Aug 18 '16 at 06:54 PM

Yeah, not submitting binaries seems a bit impossible. We don't generally submit directly from developer machines, we do have a continuous build system that handles that particular magic. However most of our machines work just fine, but 10% or so seem to have this problem. While we're seeing this issue more on new machines, we've had at least one developer who has had this problem for probably over a year now. So this has been happening across multiple engine versions.

avatar image Starglider17 Aug 28 '16 at 04:17 PM

Same problem.

If you try building a new c++ project it will fail with crtdefs.h missing and corecrt.h missing. You will also get the same result from blueprint project add a c++ class.

Googling all the answers says to add paths to some option which doesn't exist.

UE4 not been working for 2+ weeks for me now, I've re-installed VS2015 but goes to upgrade 3 so it fails again. UE4 is just not compatible with VS2015 any more.

avatar image ImVawx ♦♦ STAFF Aug 29 '16 at 01:11 PM

Hey Starglider17,

If you are using 4.12.5, there shouldn't be an issue with Visual Studio upgrade 3. If there is, please make a new Answer Hub post in Bug Reports and we can further assist you.

If you are using 4.11.2, there is a fix you can download. More information on that is available here.

If you are on a earlier version than 4.11.2, sadly there isn't anything we can do. My best advice if you are on a version before 4.11.2, is to download Visual Studio Community 2013 instead of 2015. You can do that here

avatar image Starglider17 Aug 30 '16 at 12:07 AM

I have both 4.12.5 and 4.11.2, neither work.

I have asked before but got a link to a MSDN page which told me to add paths, I went on a google mission to find out where to do this, which resulted in 1 being obsoleted (file menu tools > properties), the other via the right click menu on top item when project is open and selecting properties but doesn't have the stated options or list anything c++. Then another recommendation was to make a c++ blank app, compile it and then try ue4 again, no joy. So no idea. I have even removed VS2013 and VS2015 and re-installed, still no joy.

I will post again however.

https://answers.unrealengine.com/questions/477929/ue4125-not-usable.html

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

more ▼

answered Aug 26 '16 at 01:08 PM

avatar image

ImVawx ♦♦ STAFF
6.8k 113 16 125

avatar image ZacharyLewis Sep 08 '16 at 05:53 PM

Kyle: I was able to track the crash down to plugins being asked to load before modules they required were loading. I modified the loading phases of the modules and plugins and everything works for the whole team now; however, my question remains unanswered. Why would this only fail on some machines and not others? Is there any reason this cyclic dependency didn't crash on other computers?

avatar image theonecalledtom Feb 28 '18 at 07:34 PM

As I try and expand out to some designers this is becoming a problem for me. What does "modified loading phase" entail (I see the loading phase listed for the dlls)?

(comments are locked)
10|2000 characters needed characters left

I know this is an old thread but I just recently had this problem myself when trying to launch my project. UE 4.9.2, VS 2015. The prompt for rebuild failed so I tried building it directly from VS instead. Build failed in VS with hundreds of errors. Turns out I forgot a class declaration for a component inside a header file. Once corrected, I was able to build and open my project just fine.

Try building via VS and see if any errors show up.

more ▼

answered May 04 '18 at 12:30 AM

avatar image

Peter_C
3 1 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question