x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix Travel failure, Invalid url?

I am attempting to have a level load after you complete the level. I have the level's title copied from its place in the folder.... not really sure what is returning the invalid url. Help would be appreciated.

http://imgur.com/a/5kj3s (The log that it returns.)

http://imgur.com/gallery/XoOW4 (my level blueprint)

Product Version: UE 4.12
Tags:
more ▼

asked Aug 18 '16 at 06:12 PM in Using UE4

avatar image

Drangrith
6 1 2 4

avatar image Sean L ♦♦ STAFF Aug 18 '16 at 06:27 PM

It looks like the URL that is invalid is the ThirdPersonExampleMap, but the blueprint you've shown looks like it is attempting to travel to a different map.

Is there anywhere in your project potentially where you are still attempting to travel to the ThirdPersonExampleMap?

avatar image Drangrith Aug 18 '16 at 07:11 PM

Where would I begin to look to find out? Is there a search I can use in my blueprints to make sure that I haven't done anything like that?

avatar image Drangrith Aug 18 '16 at 07:07 PM

Okay I think I may be confused. I am attempting to open another level all together, why is it taking me to the third person example map?

avatar image Sean L ♦♦ STAFF Aug 18 '16 at 07:17 PM

That's the part that I was curious about. Would you mind zipping up your project, uploading it to Dropbox, and PM'ing me a link on the forums? https://forums.unrealengine.com/member.php?160394-Sean-Flint

That way I can take a closer look at your setup and see if I can determine the root cause.

avatar image Drangrith Aug 18 '16 at 09:07 PM

Okay, I sent it. Thank you for any help you are able to give me!

avatar image Sam-S Aug 18 '18 at 06:15 PM

Exact same issue in version 4.20.1. Currently participating in the Unreal Summer Game Jam and my project just did this.

Error itself: https://gyazo.com/5fe64dd43cdd4ffe099a703bf0258d29

This occured when I clicked a menu button that was created inside of a widget blueprint

Widget BP Code: https://gyazo.com/703e42491117c6e19ac1fc4d9b668491

Directory: https://gyazo.com/e2049af0ec537145db44037b0ddcfb93

I attempted to move things over to a backup copy which I had saved (so I would have to do less work to reproduce what I had already done) and it happened again.

avatar image omar-iero-stump Aug 19 '18 at 01:56 AM

Im literally getting the same error and im fairly new to unreal engine i have a main menu displaying a widget and on pressed is open level level1 i double checked the name is correct and re done the blueprint but same error, it opens up for a split second u can see but then closes with the error? Is it a bug? As i have installed 4.20 after it wasnt working on 4.19 yet still the same

avatar image Sam-S Aug 19 '18 at 03:58 PM

Yes, it is a bug. I have found out what causes it (at least in my case) and am taking steps to avoid it. I uploaded a video of me reproducing the bug below

avatar image omar-iero-stump Aug 19 '18 at 07:18 PM

thanks man, i mean another way to do respawn i might try instead is killzactor for now

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hello,

After further investigation, this appears to be a bug. As a result I've entered a report, which you can track here: https://issues.unrealengine.com/issue/UE-34943

Have a great day

more ▼

answered Aug 19 '16 at 02:45 PM

avatar image

Sean L ♦♦ STAFF
44.4k 485 147 435

avatar image Drangrith Aug 19 '16 at 03:20 PM

Thank you kindly!

avatar image Drangrith Aug 19 '16 at 03:22 PM

Would you have happened to see anything else blatantly wrong with my setup? (Any advice is good advice when you are starting out.)

avatar image Sean L ♦♦ STAFF Aug 19 '16 at 03:23 PM

I'd recommend using blueprints with a box collision component instead of the trigger volumes in the level blueprint.

I highly recommend running through some of these tutorials to get familiarized with blueprints: https://docs.unrealengine.com/latest/INT/Engine/Blueprints/index.html

Enjoy!

avatar image Drangrith Aug 19 '16 at 03:24 PM

I will, thanks again!

avatar image Daryn36 May 14 '17 at 11:10 PM

Currently having the same issue in engine 4.15. How would I open a new level without getting this bug? Creating a blueprint with a box collision to open a new level seems very time consuming when you have to make 20+ blueprints for 20+ levels. Posting here as to not ask the same question twice.

avatar image Sean L ♦♦ STAFF May 15 '17 at 01:54 PM

You can try unchecking the Absolute bug on your Open Level node, or double check to ensure that the URL you are traveling to is valid.

avatar image BonecrusherOEF Apr 11 '18 at 06:13 AM

Is there a solid solution for this yet? I'm running into pretty much the same issue. Should I just change the title of my map back to ThirdPersonExampleMap? Thanks!

avatar image Victor Spaz Popa Apr 21 '18 at 04:43 AM

Bonecrusher - is it just the error as described? you just do a load map and that's it?

a printscreen would help, to see your BP

avatar image BonecrusherOEF Apr 21 '18 at 06:00 AM

I started a brand new project and everything seems fine. Thanks for responding though.

(comments are locked)
10|2000 characters needed characters left

I have figured out how to reproduce the bug, and have done so in a video here: https://youtu.be/0LdKSaQdW30

more ▼

answered Aug 19 '18 at 03:52 PM

avatar image

Sam-S
1 1 1

(comments are locked)
10|2000 characters needed characters left

I encountered this problem as well and found a fairly easy solution for this.

If you start the game via the Play button, it seems that UE will only render the current level, therefore travelling to another level will result in an error. To make Unreal build all levels, launch the game via the Launch button.

Unreal Engine: Play button next to Launch button

unreal.png (7.1 kB)
more ▼

answered Dec 06 '18 at 08:29 PM

avatar image

csandner
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question