x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 preview 2 Media texture goes black on GearVR

hello,

I've been working on my GearVR project which is about to create an application to play 360 movie. Since,I've already done this in 4.12 and everything has worked correctly but the limitation of video's quality seem too low (Because the media texture was put on the sphere's surface) even though the resolution is Full-HD. So,I've decided to use 4K movie but for 4.12 the result still the same(low quality). After that, I think i should wait for 4.13 because 4.13 claim to support 4K movie(without reducing the resolution).
For 4.13 preview 2, I've tested the packaged game(win 64 bit platform) everything work correctly and video's resolution look like 4K. When i test on gearVR (samsung s7 edge), media texture goes black. First time i think the 4K resolution is too high for the mobile platform, so i try the lower quality including HD and Full HD. All of this doesn't work the media texture still black. I think there are two possible reasons. The first reason is my game can't find my video file and another reason will be some problem with shading or rendering process. I prove the first assumption by using "Open Source" node like this picture. alt text Print out the result to see what happen and the result is true that means it has found and loaded video, am I right? but the media texture still black. This is my level blueprint. alt text

alt text

and this is my material settings. Every materials in my project has been set to fully roughness and unlit shading model.

alt text

My scene is very simple it contains just 2 cube , 2 sphere and 1 player start. There are no light source,visual effect and any volume. In my content folder, there is a "Movies" folder for my .mp4 movie. Path of file media source has been set in term of relative path. alt text

My video codec is mp4.
Length 00:03:06
Frame width 1920
Frame height 1080
Data rate 43776 kbps
Total bitrate 43902 kbps
Frame rate 29 frames/second

Product Version: UE 4.13 Preview
Tags:
blueprint1.png (253.4 kB)
blueprint2.png (247.0 kB)
material.png (137.5 kB)
opensource.png (72.2 kB)
display.png (1.2 MB)
more ▼

asked Aug 20 '16 at 03:23 PM in VR

avatar image

Norulex
1 1 7 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I've not tried it myself yet but does anything Chris says in his comment here help? : https://forums.unrealengine.com/showthread.php?119261-4-13-How-does-the-new-media-player-work-in-4-13&p=576100&viewfull=1#post576100

My guess is your path to the content in source is incorrect - have you tried hardcoding it to begin with to see if you can get it to play at all?

more ▼

answered Aug 21 '16 at 07:35 PM

avatar image

aussieburger
1.5k 43 176 75

avatar image Norulex Aug 22 '16 at 05:12 AM

Thanks for responding Aussieburger. As I have checked MediaPlayer14.java in 4.13preview2 and the one that in github follow Chris suggestion, I found that lines that need to be add or remove have done already. Furthermore the 4.13preview2 has some extra line of code in the MediaPlayer14.java. So I think the MediaPlayer14.java is fine at this time (maybe) . About the File_Media_Source , Media_Player , Media_Playlist I have been tried these things already but it doesn't work. You can take a look at my entire blueprint (blueprint1.png , blueprint2.png) in my post.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You should not call Play right after OpenSource. It will take some time to open the media, so Play will return false and not play anything. Instead, hook into the Media Player's OnMediaOpened event to call Play.

Or better yet, check the "Play On Open" checkbox in the Media Player asset.

more ▼

answered Aug 22 '16 at 06:43 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was getting similar behaviour; worked in the editor, was black on the device. Then some media worked and some didn't which was very strange. In the end I realised it was cos some mp4's I'd made in nuke, others in ffmpeg, and that was the pattern; the ffmpeg mp4's were h264 encoded, while the nuke ones were something else.

A quick re-encode in ffmpeg ( ffmpeg -i badvid.mp4 -vcodec libx264 goodvid.mp4), and all played correctly.

more ▼

answered Dec 04 '16 at 08:25 AM

avatar image

mestela
21 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question