x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange Android Packaging Error

I'm new to Android development, and I recently decided to use UE4 for it, and I just want to do a quick test package, I installed all the software that it said to and tried to build the First Person stock setup for android, but I'm getting this error:

https://www.dropbox.com/s/zg0nhs0wfm7dzjd/UE4APKError.txt?dl=0

Any ideas?

Product Version: UE 4.12
Tags:
more ▼

asked Aug 22 '16 at 12:40 PM in Packaging & Deployment

avatar image

MaxGames64
10 1 3 5

avatar image Samantha Sutton ♦♦ STAFF Aug 23 '16 at 01:55 PM

MaxGames64,

Could you please show me what your Android SDK looks like?

Android SDK Example

Please also show me what your Project Settings > Platforms > Android settings look like for the Minimum SDK Version and the Target SDK Version.

Thanks!

androidsdk.jpg (52.6 kB)
avatar image MaxGames64 Aug 24 '16 at 08:21 AM

alt text

alt text

If there's anything else you want to see, let me know. Thanks!

apks.png (33.5 kB)
sdk.png (25.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Aug 25 '16 at 08:36 PM

Try clearing out the first 4 lines in your SDKConfig and show me what happens in your logs.

Blank SDK

My other suggestion would be to move your NVPACK to the C drive and listing it like it shows up in my initial screenshot.

Thanks!

blanksdk.png (15.3 kB)
avatar image MaxGames64 Aug 26 '16 at 08:20 AM

Here's the log with the clear SDK lines: https://www.dropbox.com/s/s66t3dicjke09ot/nosdk.txt?dl=0 And I'll try moving the NVPACK a bit later. My UE4 is in the E drive as well, so not sure if it will do anything.

avatar image Samantha Sutton ♦♦ STAFF Aug 26 '16 at 07:03 PM

Your log says at the bottom that it failed with args APP_ABI="armeabi-v7a" which states that the SDK information is missing (like I thought it would). When you have a chance, try moving NVPACK to the C drive like I have mine set up and show me the logs if it fails.

Let me know! :)

avatar image MaxGames64 Aug 29 '16 at 09:26 AM

Still having errors after move the SDK, heres the log: https://www.dropbox.com/s/dqi4qhjmvirlgz4/New.txt?dl=0

avatar image Samantha Sutton ♦♦ STAFF Aug 29 '16 at 02:45 PM

Did you install the SDK Platform for Android-19 (API-19)? If you're not sure, you can check in the Android SDK Manager and you'll be able to see which API you have installed.

Feel free to upload screenshots of your SDK Manager if you're unsure.

Thanks!

avatar image MaxGames64 Aug 30 '16 at 08:43 AM

Not sure if this is the right thing, but here it is: alt text

androidsdk.png (44.2 kB)
avatar image Samantha Sutton ♦♦ STAFF Aug 30 '16 at 02:52 PM

Use CodeWorks for Android 1R4 u2 and use the standard installation and see if that helps resolve your Android packaging error.

I ran 1R5 yesterday and ran into loads of trouble.

Thanks!

avatar image MaxGames64 Aug 31 '16 at 08:56 AM

I'm trying to install 1R4U2 and getting this: alt text

Thanks for all the help, by the way :)

denied.png (48.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Aug 31 '16 at 04:25 PM

Do you have Administrative Rights on your PC? Make sure you are running everything as Admin as that seems to resolve a lot of access denied troubles.

Try deleting the R11C folder before trying to install again and see if that helps.

Let me know - thanks!

avatar image MaxGames64 Sep 01 '16 at 01:18 PM

I fixed the problem and installed 1R4U2, and now UE4 is giving me this: https://www.dropbox.com/s/esevk0icpn6w4da/UpdatedSdk.txt?dl=0

avatar image Samantha Sutton ♦♦ STAFF Sep 01 '16 at 04:24 PM

Please make sure that your target Android build matches the API you installed through the SDK Manager. For example, if your target is Android-19 then you need to make sure that API-19 was installed.

Thanks!

avatar image MaxGames64 Sep 02 '16 at 08:13 AM

I have API 19 I'm pretty sure, and UE4 is set to Android 19, so I don't know what I'm missing here. Would reinstalling the SDK entirely help?

avatar image Samantha Sutton ♦♦ STAFF Sep 02 '16 at 02:58 PM

Open up your Nvidia CodeWorks for Android Component Manager and then select 'CodeWorks for Android 1R4u2' and select 'Standard'. Once you've done that, the 'Next' button should become an option, so click on 'Next' and let that install. Once that's completed, restart your computer and see if that allows you to package your project.

If it does, it means either you've forgotten to install part of the SDK or that part of the SDK that was installed may have been too far ahead of what UE4 supports.

avatar image MaxGames64 Sep 02 '16 at 04:42 PM

I followed what you said, and got this: https://www.dropbox.com/s/51735gkjg8ammpr/IDK.txt?dl=0 No idea what's causing this, and I even checked full instead of standard just to be sure.

avatar image Samantha Sutton ♦♦ STAFF Sep 02 '16 at 04:59 PM

Do you have FMOD enabled as a plugin on your project? If so, could you please disable it and try again?

avatar image MaxGames64 Sep 03 '16 at 05:17 AM

I dont have FMOD, so I dont think that would be it.

avatar image Samantha Sutton ♦♦ STAFF Sep 06 '16 at 03:14 PM

I saw 'FMod' in your logs, but it's 'MFMod'.

Please delete the Intermediate and Saved folders from your project.

Delete the Config files too, if you haven't changed any of your projects configurations. If you have changed your projects Configurations and the Intermediate and Saved folders do not resolve the issue, consider deleting the Config folder.

Upload your new logs if it fails again.

 MainFrameActions: Packaging (Android (All)): BUILD FAILED
 MainFrameActions: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:649: The following error occurred while executing this line:
 MainFrameActions: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:694: null returned: 1
 MainFrameActions: Packaging (Android (All)): Total time: 4 seconds
 MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file 'E:\UnReal Projects\MFMod\Intermediate/Android/APK/bin/MFMod-debug.apk'.
 MainFrameActions: Packaging (Android (All)): File name: 'E:\UnReal Projects\MFMod\Intermediate/Android/APK/bin/
 MainFrameActions: Packaging (Android (All)): MFMod-debug.apk'
avatar image MaxGames64 Sep 10 '16 at 01:28 PM

After deleting the Intermediate and Saved folders I now get this: https://www.dropbox.com/s/i1fkiv2fhyybpxn/Deleted%20folders.txt?dl=0

And deleting the Config folder the mobile controls get removed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Yes, deleting your Config folder will revert changes in your project back to default which can be a pain for some. That's why I suggested only if you hadn't made any changes.

The error relates back to your Project Folder/Intermediates/Android/Bin folder, but deleting your Intermediate folder should update that when it's recreated. It's possible that it comes back on the installation of supporting programs.

Just so make sure everything is covered, have you tried or completed the following:

  • Uninstalled VS2015

  • Uninstall AndroidWorks/NVPACK

  • Restarted PC

  • Clean install of VS2015 with the C++ Tools installed too

  • Installed CodeWorks (1R4 u2) standard set up

  • Restart PC again

Android Documentation

more ▼

answered Sep 13 '16 at 03:52 PM

avatar image MaxGames64 Sep 23 '16 at 11:23 AM

Sorry for the late response. After doing those steps I get this: https://www.dropbox.com/s/85g4499efxn713q/FreshInstall.txt?dl=0

avatar image Samantha Sutton ♦♦ STAFF Sep 23 '16 at 08:03 PM

To make sure you've deleted the correct file, please delete E:\UnReal Projects\MFMod\Intermediate\Android\ and repackage.

Could you also upload a screenshot of your installed plugins. To get to that location, simply open up the Epic Games Launcher and click on 'Installed Plugins' underneath your version of the engine.

Thanks!

avatar image MaxGames64 Oct 08 '16 at 11:59 AM

After deleting the android folder, I get this: https://www.dropbox.com/s/68rjz8vnqv83opl/Deleted%20android.txt?dl=0 Also, the Epic Games Launcher says that i don't have any plugins installed.

avatar image Samantha Sutton ♦♦ STAFF Oct 12 '16 at 09:24 PM

Do you have any []'s in your project name? To check go to your Project Settings > Platforms - Android > APKPackaging and look under Android Package Name.

Example: com.SamanthaCompany.SamanthaProject

Thanks!

avatar image MaxGames64 Oct 30 '16 at 01:14 PM

I did, and removing them fixed the problem. Thanks for the help!

avatar image Samantha Sutton ♦♦ STAFF Oct 31 '16 at 08:04 PM

You're welcome!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question