x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shadow maps visually different between in-game and editor viewport

When adjusting shadow parameters in UE4 editor, I often notice that the shadow preview in the U4Editor viewport does not match with the way shadows look during in-game. This makes adjusting shadows a slow and painful process due to having to continually play the game to see how shadows look when tweaking parameters.

Attached is a comparison of shadow maps in-game (left) and in the UE4 editor viewport (right). Notice the visual difference, especially the aliasing on the right image from the viewport preview. alt text

Product Version: UE 4.12
Tags:
shadowbug.jpg (240.1 kB)
more ▼

asked Aug 22 '16 at 08:44 PM in Bug Reports

avatar image

DustinBiser
1 1 2

avatar image Tim Hobson ♦♦ STAFF Aug 22 '16 at 10:01 PM

This looks like you've not got your Engine Scalability set to EPIC. You can check this by going to World Settings > Engine Scalability.

avatar image DustinBiser Aug 23 '16 at 04:38 PM

@Tim, thanks for your response. Engine Scalabilty settings are all set to EPIC, so I believe this is a bug.

alt text

avatar image Ed Burgess ♦♦ STAFF Aug 24 '16 at 03:31 PM

Hey Dustin,

I'm having difficulty reproducing your issue. Can you reproduce this issue in a blank project with minimal assets? If so could you provide a list of steps that led to this bug?

While testing here is what I did:

  1. Opened a blank project without starter content.

  2. In the default scene I added a basic sphere mesh and moved it up until it rested just above the floor

  3. I deleted the Skysphere and Atmospheric Fog asset in scene

  4. Rotated the Light Source so that the rotation was 0,-90,0

  5. Built Lighting only

  6. Played the level in Standalone Game

I've attached screenshots of the results.

alt text

shadows.jpg (150.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Dustin,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

more ▼

answered Aug 29 '16 at 01:25 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question