x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Engine TRASHCLASS

Hello there,

I'm getting a lot of those:

 [2016.08.24-09.38.48:477][102]BlueprintLog: New page: Compile SceneGameMode
 [2016.08.24-09.39.01:738][320]LogWindows: Windows GetLastError: L’opération a réussi. (0)
 [2016.08.24-09.39.02:054][320]LogCrashTracker: 
 [2016.08.24-09.39.02:054][320]LogCrashTracker: 
 [2016.08.24-09.39.02:054][320]LogWindows:Error: === Critical error: ===
 Fatal error: [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Engine\Private\BlueprintGeneratedClass.cpp] [Line: 148] 
 UBlueprintGeneratedClass::GetAuthoritativeClass: ClassGeneratedBy is null. class '/Engine/Transient.TRASHCLASS_BubbleWidget_87'
 [2016.08.24-09.39.02:084][320]LogExit: Executing StaticShutdownAfterError

The problem is that BubbleWidget is an old BP class that isn't in our project since a long time. It crashes randomly, sometime when compiling classes (which didn't have any connection with this old BP), sometimes when drawing connections between nodes within a BP, sometimes at project loading. We tried on Mac and Windows: same problem.

Already tried to delete the Intermediate and Saved folders but no positive results. Even try to build a project from scratch (migrating the BPs) but no more luck.

Version: 4.12.5-3039270 Systems: Windows 10 + Mac OS Sierra

Thanks for your precious help.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 24 '16 at 09:51 AM in Bug Reports

avatar image

bricefr
1 1 3

avatar image Adam Davis STAFF Aug 26 '16 at 01:51 PM

Hi bricefr,

TRASHCLASS errors often occur as a result of NULL pointers. Run "Fix Up Redirectors" on the Contents folder, additionally check your blueprints to ensure that you aren't passing any NULL values into any blueprints.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi bricefr,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please try the solutions listed above and respond here with updated information.

more ▼

answered Aug 29 '16 at 03:05 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question