x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

[Closed] [SOLVED] 'LightPropagationVolumeBlendable.generated.h' file not found

I've downloaded the source for 4.13 branch from GitHub. It compiled ok etc.. I've opened a project. When I try to package this project for Android I get this error:

 UATHelper: Packaging (Android (ATC)): UnrealBuildTool: [45/228] clang++.exe Module.Engine.27_of_34.cpp [armv7-es2]
 UATHelper: Packaging (Android (Multi:ATC,ASTC,ETC1)): UnrealBuildTool: In file included from C:/UnrealTEST/CidadeLixiana/Intermediate/Build/Android/CidadeLixiana/Shipping/Engine/Module.Engine.27_of_34.cpp:18:
 UATHelper: Packaging (Android (Multi:ATC,ASTC,ETC1)): UnrealBuildTool: In file included from A:\Libraries\Programs\Dev\Unreal\UnrealEngine-4.13\Engine\Source\Runtime\Engine\Private\SceneView.cpp:20:
 UATHelper: Packaging (Android (Multi:ATC,ASTC,ETC1)): UnrealBuildTool: ../Plugins/Blendables/LightPropagationVolume/Source/LightPropagationVolumeRuntime/Public\LightPropagationVolumeBlendable.h(7,10) :  fatal error: 'LightPropagationVolumeBlendable.generated.h' file not found
 UATHelper: Packaging (Android (Multi:ATC,ASTC,ETC1)): UnrealBuildTool: #include "LightPropagationVolumeBlendable.generated.h"
 UATHelper: Packaging (Android (Multi:ATC,ASTC,ETC1)): UnrealBuildTool:          ^

I've built the Engine in Development Mode for Android platform. Also tried Shipping and the problem persists. What else do I have to do to package for Android using the source?

Also, why is it performing 228 actions whereas Launcher version only does about 11?

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 24 '16 at 01:15 PM in Packaging & Deployment

avatar image

RVillani
1.1k 28 39 90

avatar image RVillani Aug 24 '16 at 01:37 PM

Wow, Sean! That was fast! Thanks a lot for your time!

Indeed I had it disabled as Android can't use it (AFAIK). After enabling it and restarting the editor, it asked to compile the Module's dll. That'll probably solve it. Trying to package right now. I'll come back to you with the outcome.

avatar image RVillani Aug 24 '16 at 01:44 PM

It's packaging. In the mean time, would you mind explaining to me why it performs 200+ clang++ actions versus the 11 on the Launcher version?

avatar image Sean L ♦♦ STAFF Aug 24 '16 at 02:23 PM

Keep me updated on if this resolves the issue.

As far as your other question goes, please create a new thread as it is unrelated to the main topic of this thread.

Thanks!

avatar image RVillani Aug 24 '16 at 02:35 PM

Haha ok. I thought it was simple XD

Sean, your solution worked. Turning the plugin on did the trick. I'll mark it as SOLVED and, if possible, change the section as it isn't a bug, but a dumb user problem :P

EDIT: I can't remove it from Bug Reports. Can you? Also, please convert your first comment to an answer =) I can't do it myself.

(comments are locked)
10|2000 characters needed characters left

The question has been closed Aug 30 '16 at 08:51 PM by RVillani for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hello,

Do you have the Light Propogation plugin enabled? If not, go ahead and go to Edit->Plugins and enable it. Then attempt to package again.

Let me know if that helps.

more ▼

answered Aug 24 '16 at 01:23 PM

avatar image

Sean L ♦♦ STAFF
43.8k 485 152 440

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question